Actions

Help33 talk

Components Joomla Update

From Joomla! Documentation

Request for arbitrage: update to current removed

Request for arbitrage: Changed the description to note that an update goes for the current version. Think the destinction is relevant because it doesn't allow you to pick one, it decides for you and picks the current one. Sovainfo (talk) 05:21, 1 May 2014 (CDT)

Agreed, the update is only the most current one. You do not have a choice if on 3.2.0 to update to 3.2.1, you'll get 3.2.4 or 3.3.0. Tom Hutchison (talk) 07:53, 1 May 2014 (CDT)
Sorry but you are incorrect because the update version can be defined in an xml file situated on a URL defined in the 'Custom' Server field. Topazgb 13:21, 1 May 2014 (CDT)
One has nothing to do with the other, but I can see what you are thinking. The problem is the word 'current' is used as it should be. The goal is to keep the users on the 'current' release, not a previous release. "A/an" is indefinite and "the" is specific. "A" current update would imply a non specific choice or even multiple choices for the end user. "The" current update would be the specific update offered, the "current" update. Since users aren't presented with a choice of updates, e.g. 3.0 installed, update to 3.1.0, 3.0.1, 3.2.4, 3.3.0, now pick one, "the current update" is appropriate as it is one specific update. Even if a user changes to a custom URL, different server(LTS or STS), only one update is presented, which may not be the current one, but to the component it is the current one(higher version compared to what is installed). Hope that helps. Tom Hutchison (talk) 09:33, 2 May 2014 (CDT)
The Second sentence (of the help page)describes that there are choices of the different update servers ... but the first sentence only specifies the result of the default setting. ergo the first sentence (of the help page is inaccurate.
"This screen allows Joomla! to be updated quickly by downloading the current update package" is inaccurate/incomplete because it only allows for the downloading of the current update package with the default/pre-set settings. Therefore the definite article 'the' is being incorrectly used because it is possible to download any update version.
In short ... that screen can be used to download any update version not just "the current update package"
--Topazgb 11:36, 2 May 2014 (CDT)


Now it states it is the default. While I was at it, noted the change of the server is for advanced users.
So why would you want users to use a specific, unsupported update? Devs on the testing server are advanced users, regular users should always be using the latest version.
The help screen's job is to give help to the common, everyday users. You are splitting hairs on the 99%(targeted audience) vs the 1%(highly advanced users/developers). Tom Hutchison (talk) 10:03, 3 May 2014 (CDT)


I do not "want users to use a specific, unsupported update" ... And I am not splitting hairs. There may be experienced Web masters who are not familiar with Joomla and (for a number of reasons) wish to use a specific update. Giving accurate information will help them without hindering the average user. But inaccurate information (by way of inferring only the current update can be downloaded from that screen) can cause a misconception for experienced Web masters that wish to experiment with Joomla. --Topazgb 11:14, 3 May 2014 (CDT)

I would like to see (a link to) an example xml file that updates to J3.2.3. Also the description of 4.1 should be changed so webmasters know when to choose the last two options. Sovainfo (talk) 20:29, 3 May 2014 (CDT)

@Sovainfo As requested http://www.weblinksonline.co.uk/testupdate/update3.2.3.xml Method to replicate

  1. Install any version of Joomla prior to 3.2.3
  2. In Joomla! Update Component
  3. Set Update server to 'Custom URL'
  4. In the 'Custom URL' field put http://www.weblinksonline.co.uk/testupdate/update3.2.3.xml
  5. 'Save and Close'

You should then see the download for http://joomlacode.org/gf/download/frsrelease/19240/158108/Joomla_3.2.x_to_3.2.3-Stable-Patch_Package.zip --Topazgb 08:54, 4 May 2014 (CDT)

4.1 is automated, would need to change the form field tool tip in core to change it. After investigating more, updater works on a greater than. 4.0.14 must be greater than the installed, 4.0.11. You can point to a XML file, but must point to a greater than version to get update is available. You can not regress, 4.0.14 to 4.0.11. The example is a testing URL example, not real world practical for everyday users. URL practical uses, development, testing or a developer supplying a custom update to their client(s). The last example, a custom component or core addition or changes, which obviously is more work for a developer. This statement:

There may be experienced Web masters who are not familiar with Joomla and (for a number of reasons) wish to use a specific update.

is not an accurate use of updater. The specific update must always be greater than the version installed. I can't think a a reason off-hand why an experience webmaster would "want to target" an update, especially if they are not familiar with Joomla. An truly experienced webmaster knows better than to tweak settings they don't understand fully.
In any regards, I think we are past the point of putting this to rest. Thanks for all the input, the use of "the current update" will stay in place. Thanks Tom Hutchison (talk) 09:06, 4 May 2014 (CDT)

Proposed changes to 4.1

Understand that this section is automated. Wonder why 4.1 doesn't mention the two fields separately. The Custom URL description doesn't make sense to me. It is in the list of options but describes the field where you enter the url itself. The option should be described as Pick this when you want to specify your own update server. Provide the url in Custom URL data entry field. Description for Custom URL data entry field should be something like Provide your own url here, only applicable when update server is set to Custom URL.

Suggest to change "Currently configured (no change)" to "No update server".Sovainfo (talk) 09:53, 4 May 2014 (CDT)


Agreed ... the 'Custom URL' setting has the description of the 'Custom URL' field ... have edited to specify the difference.

'Currently configured (no change)' is the name of an option in the 'Update server' drop down' list and therefore is correct in the documentation. --Topazgb 10:16, 4 May 2014 (CDT)

I will keep an eye for the changes coming so we can address all of these tweaks and changes at the same time. The use of LTS and STS do not fit in with the new development strategy. The problem is... LTS/STS are deeply entangled with our terminology and used everywhere. I far as I know, we have not discussed any changes to the update component, e.g. LTS to Current Major and STS to Most Current Major. One would indicate, stay on the major you are on. The other, check to see if there is a higher major version. Technically, 2.5 and 3.x are now both current supported versions. 2.5 just has a EOL set with no feature releases. Docs will have to make a lot of changes too. We use LTS and STS everywhere in templates to output version numbers. That will have to change too. My first order of business will be to get rid of Help31 or Help33 and all the aliases to a set permanent Help3x. Same for J3.2 or now J3.3 namespace to J3.x. Actually, I can go ahead and do both. Help3x is a bit more complicated. I would like to see the core's Help link formation change at core level. FYI, 3.4 is supposed to mark our first release under new strategy so this is why I am holding off. Tom Hutchison (talk) 10:23, 4 May 2014 (CDT)

Custom URL section

@Topazgb: Thanks for providing the information on the XML. Actually meant this information to be provided in the help document. Not the step by step instructions, the higher level of information. No need to tell an experienced webmaster to press buttons. The xml contents with the example information and instructions what to change for their situation. And how to find that information. Sovainfo (talk) 09:53, 4 May 2014 (CDT)

@Sovainfo When setting out PoC it is customary to list the exact steps ... that is why I gave 'step by step' when answering your request. However as for documentation for creating an xml for a custom update server ... http://docs.joomla.org/Deploying_an_Update_Server gives the basics. It covers updating third party extensions as well as updating Joomla to a specific version.

So, do you suggest to only link to http://docs.joomla.org/Deploying_an_Update_Server in the help?Sovainfo (talk) 14:38, 4 May 2014 (CDT)