Actions

Compatibility changes

From Joomla! Documentation

Revision as of 06:42, 11 March 2011 by Mariusvr (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

The purpose of this page is to allow for easy tracking of compatibility changes from Joomla 1.6 onwards. It is the intention to not introduce any backward incompatibility, however sometimes these changes are nessecary to ensure Joomla advances. 3rd party developers should check this page often, as compatibility changes will be listed here before they are released.

To view compatibility changes going from Joomla 1.5 to Joomla 1.6, please view the following page: http://docs.joomla.org/Tutorial:Upgrade_Joomla_1.5_Extension_to_Joomla_1.6

Joomla 1.6.1

Desciption: token now required in logout links
Affects: login modules and administrator templates
Details: To generate a logout link use the following code

JRoute::_('index.php?option=com_login&task=logout&'. JUtility::getToken() .'=1');