Actions

Difference between revisions of "Extension Installer/Triggers/onAfterExtensionUpdate"

From Joomla! Documentation

< Extension Installer‎ | Triggers
(New page: The onAfterExtensionUpdate trigger occurs after the update of an extension. It has a single parameter: * '''installer'''<br>A copy of the installer instance that was used. This it to get a...)
 
 
Line 1: Line 1:
The onAfterExtensionUpdate trigger occurs after the update of an extension. It has a single parameter:
+
The onAfterExtensionUpdate trigger occurs after the update of an extension. It has a two parameters:
 
* '''installer'''<br>A copy of the installer instance that was used. This it to get access to any error messages that might have occured.
 
* '''installer'''<br>A copy of the installer instance that was used. This it to get access to any error messages that might have occured.
 
* '''eid'''<br>The extension ID of the installed extension. The extension ID may be either a valid numeric value (positive integer), a zero value (when the extension doesn't have a corresponding entry in the extensions table but it is valid; a combined 1.5 language pack behaves this way) or false if the installation failed.
 
* '''eid'''<br>The extension ID of the installed extension. The extension ID may be either a valid numeric value (positive integer), a zero value (when the extension doesn't have a corresponding entry in the extensions table but it is valid; a combined 1.5 language pack behaves this way) or false if the installation failed.

Latest revision as of 23:50, 24 September 2008

The onAfterExtensionUpdate trigger occurs after the update of an extension. It has a two parameters:

  • installer
    A copy of the installer instance that was used. This it to get access to any error messages that might have occured.
  • eid
    The extension ID of the installed extension. The extension ID may be either a valid numeric value (positive integer), a zero value (when the extension doesn't have a corresponding entry in the extensions table but it is valid; a combined 1.5 language pack behaves this way) or false if the installation failed.