Actions

Difference between revisions of "External Libraries in Joomla"

From Joomla! Documentation

(Mootools More: Add MT More version)
(Fix formatting, add 2.5 notes about what isn't shipped)
Line 1: Line 1:
 
==Mootools==
 
==Mootools==
"1.4.5 with 1.2 compatibility layer" - Joomla 2.5
+
* ''1.4.5 with 1.2 compatibility layer'' - Joomla 2.5
''1.4.5'' - Joomla 3.0 - Present
+
* ''1.4.5'' - Joomla 3.0 - Present
  
 
==Mootools More==
 
==Mootools More==
"1.4.0.1" - Joomla 2.5 - Present
+
* ''1.4.0.1'' - Joomla 2.5 - Present
  
 
==jQuery==
 
==jQuery==
''1.8.3'' - Joomla 3.1 - Present
+
* ''1.8.3'' - Joomla 3.1 - Present
''1.8.1'' - Joomla 3.0 - 3.0.3
+
* ''1.8.1'' - Joomla 3.0 - 3.0.3
 +
 
 +
Note: jQuery is not distributed with Joomla 2.5
  
 
==jQuery UI==
 
==jQuery UI==
 
(Core, Widget, Mouse, Position, and Sortable)  
 
(Core, Widget, Mouse, Position, and Sortable)  
''1.8.23'' - Joomla 3.0 - Present
+
* ''1.8.23'' - Joomla 3.0 - Present
 +
 
 +
Note: jQuery UI is not distributed with Joomla 2.5
  
 
==Bootstrap==
 
==Bootstrap==
''2.3.2'' - Joomla 3.1.2 - Present
+
* ''2.3.2'' - Joomla 3.1.2 - Present
''2.1.0'' - Joomla 3.0 - 3.1.1
+
* ''2.1.0'' - Joomla 3.0 - 3.1.1
 +
 
 +
Note: Bootstrap is not distributed with Joomla 2.5
  
 
[[Category:Development Reference]]
 
[[Category:Development Reference]]

Revision as of 19:56, 28 June 2013

Contents

Mootools

  • 1.4.5 with 1.2 compatibility layer - Joomla 2.5
  • 1.4.5 - Joomla 3.0 - Present

Mootools More

  • 1.4.0.1 - Joomla 2.5 - Present

jQuery

  • 1.8.3 - Joomla 3.1 - Present
  • 1.8.1 - Joomla 3.0 - 3.0.3

Note: jQuery is not distributed with Joomla 2.5

jQuery UI

(Core, Widget, Mouse, Position, and Sortable)

  • 1.8.23 - Joomla 3.0 - Present

Note: jQuery UI is not distributed with Joomla 2.5

Bootstrap

  • 2.3.2 - Joomla 3.1.2 - Present
  • 2.1.0 - Joomla 3.0 - 3.1.1

Note: Bootstrap is not distributed with Joomla 2.5