Actions

Difference between revisions of "Installer"

From Joomla! Documentation

(Using the the Joomla! Installer)
(Using the the Joomla! Installer)
Line 26: Line 26:
 
**Your webserver's PHP version must be over 4.3.10
 
**Your webserver's PHP version must be over 4.3.10
 
    
 
    
*Compression support for zlib
+
*Zlib Compression Support 
 
*XML support
 
*XML support
 
*MySQL support   
 
*MySQL support   
*Directive MB string language by default   
+
*MB string language by default   
*Directive MB string overload deactivated   
+
*MB string overload deactivated   
*Modifiable configuration.php file
+
*Writable configuration.php file
 
**Create a file named configuration.php on root or rename the default one from the package(configuration.php-dist)
 
**Create a file named configuration.php on root or rename the default one from the package(configuration.php-dist)
 +
'''Recommended settings:'''
  
 
*Safe Mode
 
*Safe Mode

Revision as of 04:38, 15 January 2009

Copyedit.png
This Article Needs Your Help

This article is tagged because it NEEDS REVIEW. You can help the Joomla! Documentation Wiki by contributing to it.
More pages that need help similar to this one are here. NOTE-If you feel the need is satistified, please remove this notice.


Using the the Joomla! Installer

Once your files have been uploaded to the hosting space using an FTP client, it is time to install Joomla!.

First open an Internet Browser and type in the address of your Joomla! installation directory. For example:

yourdomain.com/joomlainstallationdirectory

or if you are running from your local server, type:

 http://localhost/name of your joomla site/installation/index.php


Screen 1: After the correct address is entered, the image below will appear. Joomla! has redirected you to the /installation subdirectory. In this step you can choose the default language (English) or anyother one.

Installer Lang.jpg


Screen 2: Click 'Next' and Joomla! displays the Pre-Installation Checklist. Specific details relating to PHP settings are outlined here. To proceed with the installation, all the lights should be green and set to Yes.

Installer PreCheck.jpg

Explanation about terms: (TECHNICAL REVIEW NEEDED OF THIS EXPLANATION)

  • PHP version must be 4.3.10 or greater than 4.3.10
    • Your webserver's PHP version must be over 4.3.10
  • Zlib Compression Support
  • XML support
  • MySQL support
  • MB string language by default
  • MB string overload deactivated
  • Writable configuration.php file
    • Create a file named configuration.php on root or rename the default one from the package(configuration.php-dist)

Recommended settings:

  • Safe Mode
  • Display Errors
  • File Transfer
  • Magic Quotes Runtime
  • Register Globals
  • Output Buffering
  • Session autostart


Screen 3: Click 'Next' and the licence prompt below will appear.GNU/GPL

Installer GNUGPL.jpg


Screen 4: Click 'Next' to enter the Database specifics. Guidelines are provided on the right-hand side to assist in completing the text fields properly. Please note that all data must be entered correctly to avoid errors.

Installer FTP.jpg


Screen 5: Click 'Next' to enter the FTP settings. This allows Joomla! to operate in a more secure way, eliminating the need for PHP to handle file upload requests. Note: The FTP layer is not necessary on Windows servers.

Installer FTP.jpg


Screen 6: Click 'Next' to enter the Main Configuration details.

Installer MainConfig.jpg


Screen 7: Click 'Next' and a warning to delete the installation directory will appear. Once that is done (most likely using FTP client, click either the 'View Site' tab or the 'Administrator' tab to continue using Joomla!.