Actions

J3.x

CLI Applications Broken

From Joomla! Documentation

Revision as of 18:20, 11 August 2013 by Tom Hutchison (Talk | contribs)

Because of changes made to JTable, CLI and other stand alone applications that use JTable break in Joomla 3.1.3 and later.

What is the Cause

This is because you now must also load the legacy and cms libraries in order to work with JTable.

Relevant Versions

Info non-talk.png
General Information

This pertains only to Joomla! version(s):- 3.1.3  3.1.4  3.1.5


How to Fix

Adding this code to your application should fix the issue.

jimport('joomla.observer.mapper');
jimport('cms.helper.tags');
jimport('cms.table.corecontent');
// Categories is in legacy for CMS 3 so we have to check there.
JLoader::registerPrefix('J', JPATH_PLATFORM . '/legacy');
        JLoader::Register('J', JPATH_PLATFORM . '/cms');

You may also need to load some other classes Hot fix.

The hotfix at this location can also be applied if you do not want to or cannot modify your application.