Actions

J3.2

Difference between revisions of "Creating a simple module/Introduction"

From Joomla! Documentation

< J3.2:Creating a simple module
(Create Intro page)
 
m (navbar at top)
Line 1: Line 1:
{{Chunk30:Creating a Simple Module for Joomla!3.x - Contents}}
 
== Requirements ==
 
You need the latest version of Joomla! 3.x (with  PHP, MySQL, Apache and Microsoft II) for this tutorial (as of writing currently 3.1.1)
 
 
== Introduction ==
 
 
Joomla! 3.x is constructed using three different applications:
 
Joomla! 3.x is constructed using three different applications:
 
* installation (used for installing Joomla)
 
* installation (used for installing Joomla)
Line 10: Line 5:
  
 
The installation application is used once. The administrator and public are used through the concept of ''components'' with ''modules''. Each module has a single entry point located in the ''modules'' directory. This is called ''mod_modulename/modulename.php'' (the ''mod_'' prefix is a historical trace)
 
The installation application is used once. The administrator and public are used through the concept of ''components'' with ''modules''. Each module has a single entry point located in the ''modules'' directory. This is called ''mod_modulename/modulename.php'' (the ''mod_'' prefix is a historical trace)
 +
 +
== Requirements ==
 +
You need the latest version of Joomla! 3.x (with  PHP, MySQL, Apache and Microsoft II) for this tutorial (as of writing currently 3.1.1)
  
 
== Contributors ==
 
== Contributors ==

Revision as of 09:33, 6 October 2013

Joomla! 3.x is constructed using three different applications:

  • installation (used for installing Joomla)
  • administrator (used for managing content)
  • public (used for displaying content)

The installation application is used once. The administrator and public are used through the concept of components with modules. Each module has a single entry point located in the modules directory. This is called mod_modulename/modulename.php (the mod_ prefix is a historical trace)

Requirements

You need the latest version of Joomla! 3.x (with PHP, MySQL, Apache and Microsoft II) for this tutorial (as of writing currently 3.1.1)

Contributors