Actions

Difference between revisions of "Joomla! 1.5 Specific FAQs"

From Joomla! Documentation

(Where is the static content?)
(Will my 1.0 extensions still work?)
Line 67: Line 67:
  
 
===Will my 1.0 extensions still work?===
 
===Will my 1.0 extensions still work?===
 +
 +
There is a legacy system in place that will allow extensions that are not 1.5 compatible to continue to operate. However, we strongly recommend that you update to the current version of all extensions prior to migration and that you check each extension's home page for specific recommendations about migration for that extension.
 +
 +
To activate the legacy support, go to the plugin manager and enable the legacy plugin.
 +
 
===How do I create a custom module?===
 
===How do I create a custom module?===
 
===How do I set global preferences for content?===
 
===How do I set global preferences for content?===
 
===Why won't my legacy extension install?===
 
===Why won't my legacy extension install?===

Revision as of 08:40, 19 January 2008

Contents

What is a Release Candidate (RC)?

In the software development cycle, a release candidate is a release that could potentially be a final product. A release candidate can be used for production sites, but it is still possible that changes could be made prior to the general release.

Do I have to upgrade to version 1.5?

For the time being the Joomla! 1.0.x release will continue to be supported and updated if security or other major issues arise. Eventually, support for the 1.0.x will cease, but this will not be in the near future.

How do I install Joomla! 1.5?

Instructions for installation can be found here. http://help.joomla.org/content/section/48/302/

How do I upgrade to Joomla! 1.5?

You can migrate a Joomla! 1.0.x site or a Mambo 4.5.x to Joomla! 1.5.

Joomla 1.5 does not provide an upgrade path from earlier versions. Converting an older site to a Joomla 1.5 site requires creation of a new empty site using Joomla 1.5 and then populating the new site with the content from the old site. This migration of content is not a one-to-one process and involves conversions and modifications to the content dump.

There are two ways to perform the migration:

  • An automated method of migration has been provided which uses a migrator component to create the migration dump out of the old site (Mambo 4.5.x up to Joomla 1.0.x) and a smart import facility in the Joomla 1.5 Installation that performs required conversions and modifications during the installation process.
  • Migration can be performed manually. This involves exporting the required tables, manually performing required conversions and modifications and then importing the content to the new site after it is installed.

Automated migration

This is a two phased process using two tools. The first tool is a migrator component named 'com_migrator'. This component has been contributed by Harald Baer and is based on his 'eBackup' component. The migrator needs to be installed on the old site and when activated it prepares the required export dump of the old site's data. The second tool is built into the Joomla 1.5 installation process. The exported content dump is loaded to the new site and all conversions and modification are performed 'on-the-fly'.

Step 1 - Using com_migrator to export data from old site:

  • Install the com_migrator component on the old site. It can be found at joomlacode.org .
  • Select the component in the component menu of the administrator.
  • Click on the 'Dump it' icon. Three exported gzipped export scripts will be created. The first is a complete backup of the old site. The second is the migration content of all core elements which will be imported to the new site. The third is a backup of all 3PD component tables.
  • Click on the download icon of the particular exports files needed and store locally.
  • Multiple export sets can be created.
  • The exported data is not modified in anyway and the original encoding is preserved. This makes the com_migrator tool a recommended tool to use for manual migration as well.

Step 2 - Using the migration facility to import and convert data during Joomla 1.5 installation:

Note: This function requires use of the iconv function in PHP to convert encodings. If iconv is not found a warning will be provided.

  • In step 6 - Configuration select the 'Load Migration Script' option in the 'Load Sample Data, Restore or Migrate Backed Up Content' section of the page.
  • Enter the table prefix used in the content dump. For example: '#_' or '#__' are acceptable values.
  • Select the encoding of the dumped content in the dropdown list. This should be the encoding used on the pages of the old site. (As defined in the _ISO variable in the language file or as seen in the browser page info/encoding/source)
  • Browse the local host and select the migration export and click on 'Upload and Execute'
  • A success message should appear or alternately a listing of db errors # Complete the other required fields in the Configuration step such as Site Name and Admin details and advance to the final step of installation. (Admin details will be ignored as the imported data will take priority. Please remember admin name and password from the old site)

What happened to the locale setting?

This is now defined in the language .xml file in the language metadata settings. If you are having locale problems (dates don't appear in your language) you might want to check/edit the entries in the locale tag. Note that multiple locale strings can be set and the host will usually accept the first one recognised.

Where did the installer go?

The improved installer can be found under the extensions option. With versions prior to 1.5 you needed to select a specific extensions type when you wanted to install it, with Joomla! 1.5 you just select the extension you want to upload, and click on install. The installer will do all the hard work for you.

Only one edit window! How do I create "Read more..."?

This is now implemented by inserting a tag (button is in the editor area) a dotted line appears in the edited text showing the split location for the "Read more...". A new bot takes care of the rest.

It is worth mentioning that this does not have a negative effect on migrated data from older sites. The new implementation is fully backward compatible.

Where did the Mambots go?

Mambots have been renamed as "Plugins" Mambots were introduced in Mambo and offered possibilities to add plugin logic to your site to mainly for the purpose of manipulating content. In Joomla!, Plugins will now have much broader capabilities than Mambots. Plugins are able to extend functionality at the framework layer as well.

Where is the static content?

In Joomla! versions prior to 1.5 there was a distinctive difference on static and normal content. Both content types are still around, but are not handled as separate items. If you want to create static content, just select "uncategorized" as section and category and the content is handled as static content.

Will my 1.0 extensions still work?

There is a legacy system in place that will allow extensions that are not 1.5 compatible to continue to operate. However, we strongly recommend that you update to the current version of all extensions prior to migration and that you check each extension's home page for specific recommendations about migration for that extension.

To activate the legacy support, go to the plugin manager and enable the legacy plugin.

How do I create a custom module?

How do I set global preferences for content?

Why won't my legacy extension install?