Actions

Joomla Browser Support

From Joomla! Documentation

Revision as of 21:51, 26 July 2012 by Rtlito (Talk | contribs)

This document lists which browsers are fully supported by a given Joomla release. In general all code should be written in a way that the content is still accessible in older browsers as well. In case Joomla doesn't work with one of the listed browser please file a bug report.

In general we will only support the newest releases of Opera and Chrome. For Internet Explorer, Firefox and Safari the current browser version at the time of Joomla's release and all future versions are supported. Also selected older versions are supported based on market share.

Note: Information for feature version may change up to the date of the release

Joomla 3.0 (July 2012)

  • Internet Explorer 8 and newer
  • Firefox 13 and newer
  • Safari 5.1 and newer
  • Chrome XY and newer
  • Opera 11.6

Joomla 2.5 (January 2012, LTS)

  • Internet Explorer 7 and newer
  • Firefox 9
  • Safari 5 and newer
  • Chrome 17
  • Opera 11.6

Checking users for browser compatibility

You can use BrowserHawk IQ [commercial] to ensure your users meet the minimum system requirements for Joomla by adding two lines of HTML to your page. It also checks other settings including OS, connection speed and latency, screen size, disabled cookies and disabled JavaScript. Users can automatically submit their browser and system configuration to your support staff for assistance if desired.

The BrowserHawk IQ rules files for Joomla are available here and you can get an account to use them here.