Actions

NetBeans overview

From Joomla! Documentation

Revision as of 15:55, 25 May 2010 by MarijkeS (Talk | contribs)

Contents

Introduction

A brief overview of how to setup the PHP edition of NetBeans follows. You would still need to consult Setting up your workstation for Joomla! development to learn about setting up your environment for Joomla! development. For the sake of brevity and not to "reinvent the wheel" we will provide references to further readings wherever we deem various topics are treated to a satisfactory extent elsewhere.

Notes

  • NetBeans here and after refer to the PHP edition of NetBeans only.
  • The following applies to all flavors of Windows and the steps should be similar or the same for other OS.
  • In many of the cases there are several ways of achieving your goal, and the coverage here is just a guideline for a new beginner and doesn't claim on being exhaustive.

About NetBeans

NetBeans provides you a modern slim PHP IDE. Very fast (even in larger projects) and good code completion, file/code/property explorer and excellent HTML/CSS/Javascript support. Subversion and xdebug support works almost out of the box as we will see below. Current version of NetBeans is 6.8. Version 6.9 with a lot of small goodies, ex. ability to detect changes outside NetBeans so far had been a bit of a mystery, ability to refactor inline css codes to external such etc., is around the corner (eta early June 2010, currently on beta status and beta is quite stable). As a last note about version 6.9, since the installation is made to version specific folders, if you want to give 6.9beta a run you can do so without interfering with your 6.8 setup.

Installation and initial configuration of NetBeans

Prerequisite: to be able to install and run NetBeans you would need Java 6 or 5. If you don't have that installed, download it from http://java.sun.com/javase/downloads/widget/jdk6.jsp.

  1. Download NetBeans (http://netbeans.org/downloads/index.html) and make sure to download the PHP version. The installation is straight forward and amounts to clicking through the installation wizard which defaults to correct and workable values.
  2. Your first run after installation will install the auto-update plugin. Please do restart after installing the plugin.
  3. Your second run will find a number of updates which you are advised to install and restart.
  4. The start page of NetBeans consisting of related news can be turned off by unchecking the "Show On Startup" checkbox at the bottom of the screen.

We are now set to go and from here we will

  • create our first hello netbeans project and do some minor debuggings
  • we will step through downloading Joomla from the svn and make changes, create patches, apply patches and get updates from svn

Creating a project and debugging

  1. Start NetBeans and choose File > New Project menu and you will be presented with the "New PHP Project" wizard.
  2. Select "PHP Application" among the Projects option. Reference: http://netbeans.org/kb/docs/php/project-setup.html.
  3. In the next step you will be given the option of configuring
    1. Project Name - give hellonb
    2. Sources Folder - where the files created within the project will be located. Although NetBeans makes an attempt to locate the server DocumentRoot, it normally fails and defaults to Apaches default htdocs, which means if you have reconfigured DocumentRoot in your httpd.conf it will not be able to point it out for you, and you will need to point out the location manually as follows. Go to your DocumentRoot folder by choosing Browse and in your DocumentRoot folder create the project folder hellonb, select the folder and click Open.
    3. Put NetBeans metadata into a separate directory - NetBeans creates a folder named nbproject containing project specific IDE settings and metadata of the project to be created. If you are working with a project in which you are about to checkout from svn, as we will see below, having this folder in your project folder is not a desired option as it eventually will be included in your export. One way of not having nbproject in such exports is to relocate nbproject from its default location, the project folder. This is done by simply checking this checkbox and pointing out where the nbproject folder should be located, outside your project folder.
    4. In the next page of the wizard make sure that the Project URL is correct, in this case http://localhost/hellonb/, depending on your setup.
    5. Its now time to press the Finish button and create the project.
  4. Although NetBeans succeeds detecting where the PHP interpreter is located and thereby also xdebug, lets make sure that this is correct by going to Tools > Options menu and click to the PHP section (among the top horizontal bar of icons). In the General tab we should be able to verify that the PHP 5 Interpreter is the correct one and that the Debugger Port option contains the same value as the xdebug.remote_port parameter in the PHP ini file of the interpreter referred to.
    1. For those who've followed the instructions at http://docs.joomla.org/Setting_up_your_workstation_for_Joomla!_development to update php.ini with
      set xdebug.remote_port=10000
      
      You need to go to Tools->Options and set the Debugger port to 10000 to match.
  5. With this behind us let us create our index.php file and put a simple statement, ex. echo "hello netbeans". Press F6 and the project should run by invoking index.php either in your default browser or one you would be able to configure in Tools > Options > General > Web Browser. With the given example, this should output "hello netbeans" in your browser.
  6. The topics of PHP debugging in NetBeans is excellently covered in http://netbeans.org/kb/docs/php/debugging.html. Another excellent resource regarding debugging with xdebug is the following comprehensive series, Introducing xdebug: http://devzone.zend.com/article/2803.

Subversion setup

In this part we will see how easy it is to configure NetBeans to work with an SVN repository for the purpose of checking out, creating patches, apply patches as well as update repository (which we will not cover in this case).

  1. Create a new project of the type "PHP Application"
  2. Check if Netbeans created an index.php file in the Source Files directory (it's located right there under the 'Projects' tab). If so, delete it before you start the checkout. If you don't it might break the checkout process.
  3. Go to Team > Subversion > Checkout...
  4. (This step is done only the first time you are running the Subversion integration) You will be prompted with the message that a Subversion client is missing and given option to install it. Choose the easiest one "Get bundled Subversion binaries for Windows..." and click OK and click through the dialogue. Once the installation finishes restart.
  5. We will now resume back from step 2 above and in the Repository URL give http://joomlacode.org/svn/joomla/development/trunk and in User give anonymous and leave Password blank.
  6. Clicking Next. NetBeans will now connect to the SVN repository and ask you to provide:
    1. Repository folder(s) to checkout from in the repository which should remain unchanged, being "development/trunk" as it was included in the Repository URL in step 3. If the field is empty for some reason do provide development/trunk.
    2. Local Folder - Browse and point out you current project folder and
    3. uncheck the "Scan for NetBeans project" checkbox and click Next.
    4. Checking out the trunk will take some minutes to finish and you will see the task status on the right of the status bar at the bottom of the NetBeans window.
  7. Let us now make a dummy change to see how to deal with the various steps of creating a patch works.
    1. Open components/com_content/content.php and make a change, ex. by inserting a comment. Once we have saved our change you will see that files that have been changed since last SVN update are now highlighted with blue. Containing folder of changed files are highlighted with a blue badge. For more on this and other features please read http://netbeans.org/kb/docs/ide/subversion.html which even if geared towards Java developers applies mostly to PHP also, and shows most of the related features of NetBeans.
    2. Assuming now that is a solution to a tracker we would like to submit it as a patch and in NetBeans you will be able to do just that at several levels, either patch extracted from the file itself only, or at an upper level up to the project level. To do that: in the Projects or Files window, click on the folder or file you want to be the position from which all changes will be extracted as patch. Go to Team > Export Diff Patch... and give the location of the file to be created and click OK.
    3. Applying patches is analogus and all features related to SVN are found under Team or Team > Subversion menu.

Resources