Actions

Difference between revisions of "Should I launch a Joomla! 2.5 site or a 3.x site?"

From Joomla! Documentation

m (update)
Line 1: Line 1:
For most new sites, the Joomla! 3 series is the preferred series and starting on it avoids a mini-migration from Joomla 2.5 later down the road.  Starting on the Joomla 3 series for a new site, also provides you with longer backward compatible support (with one-click upgrades) than starting a new site on 2.5 right now, because support for 3.x ends in 2016.
+
For new sites, the Joomla! 3 series is the preferred series and starting on it avoids an update from Joomla 2.5 later down the road.  Starting on the Joomla 3 series for a new site, also provides you with longer backward compatible support (with one-click upgrades) than starting a new site on 2.5. Joomla 2.5 will reach EOL (end of life) 31 Dec 2014.
  
When starting a new site, please plan ahead and check to make sure that any extensions (including templates) that you plan to use are Joomla 3 compatible.  If not, then Joomla 2.5 still provides you a well supported option in the meantime.
+
Sites that are currently on Joomla 2.5 are encouraged to start planning now for an upgrade to 3.3 or greater, unless you want to move over sooner to take advantage of Joomla 3’s new features.  We’ve provided a one-click upgrade from Joomla 2.5 to any Joomla 3 version and you just have to make sure that all your extensions and template are compatible before upgrading.  <includeonly>(See the “How do I find Joomla 3.x compatible extensions?” FAQ below for more information)</includeonly>
 
+
Sites that are currently on Joomla 2.5 are encouraged to stay on 2.5, until Joomla 3.5’s release, unless they need to be moved over sooner to take advantage of Joomla 3’s new features.  We’ve provided a one-click upgrade from Joomla 2.5 to any Joomla 3 version and you just have to make sure that all your extensions are compatible before upgrading.  <includeonly>(See the “How do I find Joomla 3.x compatible extensions?” FAQ below for more information)</includeonly>
+
 
<noinclude>[[Category:Version 3.0 FAQ]][[Category:Version 2.5 FAQ]]
 
<noinclude>[[Category:Version 3.0 FAQ]][[Category:Version 2.5 FAQ]]
 
[[Category:Version 3.1 FAQ]]
 
[[Category:Version 3.1 FAQ]]
 
[[Category:Version 3.2 FAQ]]
 
[[Category:Version 3.2 FAQ]]
 
</noinclude>
 
</noinclude>

Revision as of 15:55, 30 April 2014

For new sites, the Joomla! 3 series is the preferred series and starting on it avoids an update from Joomla 2.5 later down the road. Starting on the Joomla 3 series for a new site, also provides you with longer backward compatible support (with one-click upgrades) than starting a new site on 2.5. Joomla 2.5 will reach EOL (end of life) 31 Dec 2014.

Sites that are currently on Joomla 2.5 are encouraged to start planning now for an upgrade to 3.3 or greater, unless you want to move over sooner to take advantage of Joomla 3’s new features. We’ve provided a one-click upgrade from Joomla 2.5 to any Joomla 3 version and you just have to make sure that all your extensions and template are compatible before upgrading.