Actions

Difference between revisions of "Should I launch a Joomla! 2.5 site or a 3.x site?"

From Joomla! Documentation

(3 intermediate revisions by 2 users not shown)
Line 1: Line 1:
Launch a 2.5 site if you want the most stable that Joomla has to offer and/or possibly if you plan on using many extensions. Launch a 3.0 site if all the extensions that you plan to use are Joomla 3.0 compatible.  <includeonly>(See the “How do I find Joomla 3.0 compatible extensions?” FAQ below for more information)</includeonly>
+
For most new sites, the Joomla! 3 series is the preferred series and starting on it avoids a mini-migration from Joomla 2.5 later down the road.  Starting on the Joomla 3 series for a new site, also provides you with longer backward compatible support (with one-click upgrades) than starting a new site on 2.5 right now, because support for 3.x ends in 2016.
<noinclude>[[Category:Version 3.0 FAQ]][[Category:Version 2.5 FAQ]]</noinclude>
+
 
 +
When starting a new site, please plan ahead and check to make sure that any extensions (including templates) that you plan to use are Joomla 3 compatible. If not, then Joomla 2.5 still provides you a well supported option in the meantime.
 +
 
 +
Sites that are currently on Joomla 2.5 are encouraged to stay on 2.5, until Joomla 3.5’s release, unless they need to be moved over sooner to take advantage of Joomla 3’s new features.  We’ve provided a one-click upgrade from Joomla 2.5 to any Joomla 3 version and you just have to make sure that all your extensions are compatible before upgrading.  <includeonly>(See the “How do I find Joomla 3.x compatible extensions?” FAQ below for more information)</includeonly>
 +
<noinclude>[[Category:Version 3.0 FAQ]][[Category:Version 2.5 FAQ]]
 +
[[Category:Version 3.1 FAQ]]
 +
</noinclude>

Revision as of 23:41, 14 April 2013

For most new sites, the Joomla! 3 series is the preferred series and starting on it avoids a mini-migration from Joomla 2.5 later down the road. Starting on the Joomla 3 series for a new site, also provides you with longer backward compatible support (with one-click upgrades) than starting a new site on 2.5 right now, because support for 3.x ends in 2016.

When starting a new site, please plan ahead and check to make sure that any extensions (including templates) that you plan to use are Joomla 3 compatible. If not, then Joomla 2.5 still provides you a well supported option in the meantime.

Sites that are currently on Joomla 2.5 are encouraged to stay on 2.5, until Joomla 3.5’s release, unless they need to be moved over sooner to take advantage of Joomla 3’s new features. We’ve provided a one-click upgrade from Joomla 2.5 to any Joomla 3 version and you just have to make sure that all your extensions are compatible before upgrading.