Actions

Difference between revisions of "Technical requirements"

From Joomla! Documentation

m (Recommend most suitable PHP File Handlers)
m (Joomla 1.5.x {{JVer|1.5}})
(23 intermediate revisions by 9 users not shown)
Line 2: Line 2:
 
More details can be found on [http://www.joomla.org/about-joomla/technical-requirements.html Joomla.org].
 
More details can be found on [http://www.joomla.org/about-joomla/technical-requirements.html Joomla.org].
  
==Joomla 3.0.x {{JVer|3.0}}==
+
==Joomla 3.x {{JVer|3.x}}==
 
+
<section begin=Joomla 3.x />
 
{| class="wikitable" border="1"
 
{| class="wikitable" border="1"
 
!Software
 
!Software
Line 9: Line 9:
 
!Minimum
 
!Minimum
 
|-
 
|-
|PHP(Magic Quotes GPC off)
+
|PHP (Magic Quotes GPC off)
|5.3.1 +
+
|5.4 +
|5.3.1 +
+
|5.3.10 +
 
|-
 
|-
 
| colspan=3 style="background-color:#e1e1e1;" | Supported Databases:
 
| colspan=3 style="background-color:#e1e1e1;" | Supported Databases:
Line 32: Line 32:
 
|2.x+
 
|2.x+
 
|2.x+
 
|2.x+
 +
|-
 +
|Hiawatha (with [https://www.hiawatha-webserver.org/howto/url_rewrite_rules#joomla UrlToolkit] support)
 +
|latest
 +
|8.0
 +
|-
 +
|Nginx
 +
|1.1
 +
|1.0
 
|-
 
|-
 
|Microsoft IIS
 
|Microsoft IIS
Line 37: Line 45:
 
|7
 
|7
 
|}
 
|}
 +
<section end=Joomla 3.x />
  
==Joomla 2.5.x {{JVer|2.5}} - 1.7.x {{JVer|1.7}} - 1.6.x {{JVer|1.6}}==
+
==Joomla 2.5.x {{JVer|2.5}}==
  
 
{| class="wikitable" border="1"
 
{| class="wikitable" border="1"
Line 46: Line 55:
 
|-
 
|-
 
|PHP
 
|PHP
|5.3+
+
|5.4+
 
|5.2.4+
 
|5.2.4+
 +
|-
 +
| colspan=3 style="background-color:#e1e1e1;" | Supported Databases:
 
|-
 
|-
 
|MySQL<ref name="MySQL6.0" />
 
|MySQL<ref name="MySQL6.0" />
Line 53: Line 64:
 
|5.0.4+
 
|5.0.4+
 
|-
 
|-
|Apache(with mod_mysql, mod_xml, and mod_zlib)<ref name="mod_rewrite" /><ref name="PHPFileHandler" />
+
| colspan=3 style="background-color:#e1e1e1;" | Supported Web Servers:
 +
|-
 +
|Apache (with mod_mysql, mod_xml, and mod_zlib)<ref name="mod_rewrite" /><ref name="PHPFileHandler" />
 
|2.x+
 
|2.x+
 
|2.x+
 
|2.x+
 +
|-
 +
|Hiawatha (with [https://www.hiawatha-webserver.org/howto/url_rewrite_rules#joomla UrlToolkit] support)
 +
|latest
 +
|8.0
 +
|-
 +
|Nginx
 +
|1.1
 +
|1.0
 
|-
 
|-
 
|Microsoft IIS<ref name="MSIIS">For Microsoft IIS you need MySQL 5.1 or newer.</ref>
 
|Microsoft IIS<ref name="MSIIS">For Microsoft IIS you need MySQL 5.1 or newer.</ref>
Line 68: Line 89:
 
!Recommended
 
!Recommended
 
!Minimum
 
!Minimum
 +
!Not supported<ref name="NotTested">The Joomla! Project has not tested support for versions of software listed in this column.  The Joomla! CMS may function properly on these versions of software, but official support is not provided.</ref>
 
|-
 
|-
 
|PHP<ref>Do not use PHP 4.3.9, 4.4.2 or 5.0.4. These releases have known bugs that will interfere with installation. Zend Optimizer 2.5.10 for PHP 4.4.x also has serious bugs and you should ask your host to upgrade to a newer version. Joomla! versions 1.5.15 + are compatible with PHP 5.3. Note that the OpenID library is not yet compatible with PHP 5.3.</ref>
 
|PHP<ref>Do not use PHP 4.3.9, 4.4.2 or 5.0.4. These releases have known bugs that will interfere with installation. Zend Optimizer 2.5.10 for PHP 4.4.x also has serious bugs and you should ask your host to upgrade to a newer version. Joomla! versions 1.5.15 + are compatible with PHP 5.3. Note that the OpenID library is not yet compatible with PHP 5.3.</ref>
|5.2+
+
|5.2
 
|4.3.10
 
|4.3.10
 +
|5.4+
 +
|-
 +
| colspan=4 style="background-color:#e1e1e1;" | Supported Databases:
 
|-
 
|-
 
|MySQL<ref name="MySQL6.0" />
 
|MySQL<ref name="MySQL6.0" />
 
|4.1.x+
 
|4.1.x+
 
|3.23
 
|3.23
 +
|
 +
|-
 +
| colspan=4 style="background-color:#e1e1e1;" | Supported Web Servers:
 
|-
 
|-
|Apache(with mod_mysql, mod_xml, and mod_zlib)<ref name="mod_rewrite" /><ref name="PHPFileHandler" />
+
|Apache (with mod_mysql, mod_xml, and mod_zlib)<ref name="mod_rewrite" /><ref name="PHPFileHandler" />
 
|2.x+
 
|2.x+
 
|1.3
 
|1.3
 +
|
 +
|-
 +
|Hiawatha (with [https://www.hiawatha-webserver.org/howto/url_rewrite_rules#joomla UrlToolkit] support)
 +
|latest
 +
|8.0
 +
|
 
|-
 
|-
 
|Microsoft IIS<ref name="IIS">For Microsoft IIS (depending on your setup) you may need the following:
 
|Microsoft IIS<ref name="IIS">For Microsoft IIS (depending on your setup) you may need the following:
Line 90: Line 124:
 
|7
 
|7
 
|6
 
|6
 +
|
 
|}
 
|}
 +
 
==References==
 
==References==
 
<references />
 
<references />
Line 96: Line 132:
 
[[Category:Joomla! 1.5]]
 
[[Category:Joomla! 1.5]]
 
[[Category:Joomla! 1.6]]
 
[[Category:Joomla! 1.6]]
[[Category:Joomla! 1.7]]</noinclude>
+
[[Category:Joomla! 1.7]]
 +
[[Category:Joomla! 2.5]]
 +
[[Category:Joomla! 3.0]]</noinclude>

Revision as of 07:00, 2 June 2014

Contents

More details can be found on Joomla.org.

Joomla 3.x Joomla 3.x

Software Recommended Minimum
PHP (Magic Quotes GPC off) 5.4 + 5.3.10 +
Supported Databases:
MySQL[1] (InnoDB support required) 5.1 + 5.1 +
MSSQL 10.50.1600.1 + 10.50.1600.1 +
PostgreSQL 8.3.18 + 8.3.18 +
Supported Web Servers:
Apache(with mod_mysql, mod_xml, and mod_zlib)[2][3] 2.x+ 2.x+
Hiawatha (with UrlToolkit support) latest 8.0
Nginx 1.1 1.0
Microsoft IIS 7 7


Joomla 2.5.x Joomla 2.5

Software Recommended Minimum
PHP 5.4+ 5.2.4+
Supported Databases:
MySQL[1] 5.0.4+ 5.0.4+
Supported Web Servers:
Apache (with mod_mysql, mod_xml, and mod_zlib)[2][3] 2.x+ 2.x+
Hiawatha (with UrlToolkit support) latest 8.0
Nginx 1.1 1.0
Microsoft IIS[4] 7 7

Joomla 1.5.x Joomla 1.5

Software Recommended Minimum Not supported[5]
PHP[6] 5.2 4.3.10 5.4+
Supported Databases:
MySQL[1] 4.1.x+ 3.23
Supported Web Servers:
Apache (with mod_mysql, mod_xml, and mod_zlib)[2][3] 2.x+ 1.3
Hiawatha (with UrlToolkit support) latest 8.0
Microsoft IIS[7] 7 6

References

  1. 1.0 1.1 1.2 Joomla is not yet compatible with MySQL 6.x.
  2. 2.0 2.1 2.2 In order to use SEF URLs, you will need to have the Apache mod_rewrite extension installed.
  3. 3.0 3.1 3.2 The mod_suphp extension or mod_fcgid extension is recommended to enable Joomla to upload and execute files using secure file permissions.
  4. For Microsoft IIS you need MySQL 5.1 or newer.
  5. The Joomla! Project has not tested support for versions of software listed in this column. The Joomla! CMS may function properly on these versions of software, but official support is not provided.
  6. Do not use PHP 4.3.9, 4.4.2 or 5.0.4. These releases have known bugs that will interfere with installation. Zend Optimizer 2.5.10 for PHP 4.4.x also has serious bugs and you should ask your host to upgrade to a newer version. Joomla! versions 1.5.15 + are compatible with PHP 5.3. Note that the OpenID library is not yet compatible with PHP 5.3.
  7. For Microsoft IIS (depending on your setup) you may need the following: For further assistance using Microsoft IIS, visit the Joomla IIS forum.