Actions

Difference between revisions of "Technical requirements"

From Joomla! Documentation

m (This isn't a question; only the redirect page should be in the FAQ)
(Blanked the page)
Line 1: Line 1:
More details can be found on [http://www.joomla.org/about-joomla/technical-requirements.html Joomla.org].
 
  
= Joomla 1.6/1.7 {{JVer|1.6}}{{JVer|1.7}} =
 
 
{| class="wikitable" border="1"
 
!Software
 
!Recommended
 
!Minimum
 
|-
 
|PHP
 
|5.3+
 
|5.2.4+
 
|-
 
|MySQL
 
|5.0.4+
 
|5.0.4+
 
|-
 
|Apache<ref name="mod_rewrite">In order to use [[SEF URLs]], you will need to have the Apache mod_rewrite extension installed.</ref>
 
|2.x+
 
|2.x+
 
|-
 
|Microsoft IIS<ref>For Microsoft IIS you need MySQL 5.1 or newer.</ref>
 
|7
 
|7
 
|}
 
 
= Joomla 1.5 {{JVer|1.5}} =
 
 
{| class="wikitable" border="1"
 
!Software
 
!Recommended
 
!Minimum
 
|-
 
|PHP<ref>Do not use PHP 4.3.9, 4.4.2 or 5.0.4. These releases have known bugs that will interfere with installation. Zend Optimizer 2.5.10 for PHP 4.4.x also has serious bugs and you should ask your host to upgrade to a newer version. Joomla! versions 1.5.15 + are compatible with PHP 5.3. Note that the OpenID library is not yet compatible with PHP 5.3.</ref>
 
|5.2+
 
|4.3.10
 
|-
 
|MySQL
 
|4.1.x+
 
|3.23
 
|-
 
|Apache<ref name="mod_rewrite" />
 
|2.x+
 
|1.3
 
|-
 
|Microsoft IIS
 
|7
 
|6
 
|}
 
 
<references />
 
<noinclude>
 
[[Category:Joomla! 1.5]]
 
[[Category:Joomla! 1.6]]
 
[[Category:Joomla! 1.7]]</noinclude>
 

Revision as of 18:47, 2 February 2012