Actions

Technical requirements

From Joomla! Documentation

Revision as of 09:27, 8 February 2012 by Realityking (Talk | contribs)

More details can be found on Joomla.org.

Joomla 1.6/1.7/2.5 Joomla 1.6Joomla 1.7Joomla 2.5

Software Recommended Minimum
PHP 5.3+ 5.2.4+
MySQL 5.0.4+ 5.0.4+
Apache[1] 2.x+ 2.x+
Microsoft IIS[2] 7 7

Joomla 1.5 Joomla 1.5

Software Recommended Minimum
PHP[3] 5.2+ 4.3.10
MySQL 4.1.x+ 3.23
Apache[1] 2.x+ 1.3
Microsoft IIS 7 6
  1. 1.0 1.1 In order to use SEF URLs, you will need to have the Apache mod_rewrite extension installed.
  2. For Microsoft IIS you need MySQL 5.1 or newer.
  3. Do not use PHP 4.3.9, 4.4.2 or 5.0.4. These releases have known bugs that will interfere with installation. Zend Optimizer 2.5.10 for PHP 4.4.x also has serious bugs and you should ask your host to upgrade to a newer version. Joomla! versions 1.5.15 + are compatible with PHP 5.3. Note that the OpenID library is not yet compatible with PHP 5.3.