Actions

J1.5

Upgrading to 1.5 Stable

From Joomla! Documentation

Revision as of 13:32, 16 January 2008 by Chris Davenport (Talk | contribs)

Replacement filing cabinet.png
This Namespace has been archived - Please Do Not Edit or Create Pages in this namespace. Pages contain information for a Joomla! version which is no longer supported. It exists only as a historical reference, will not be improved and its content may be incomplete.
Documentation all together tranparent small.png
Under Construction

This article or section is in the process of an expansion or major restructuring. You are welcome to assist in its construction by editing it as well. If this article or section has not been edited in several days, please remove this template.
This article was last edited by Chris Davenport (talk| contribs) 6 years ago. (Purge)

It is risky to upgrade a live site without testing the upgrade process first. So before upgrading the live site you need to set up a test site which is as close as possible to the configuration of your live site, then test the upgrade on that. When you are happy with the process you can apply it to the live site (having taken a fresh backup of the live site first, of course).

Step 1: Download the correct patch package

Determine the current version of your Joomla! installation. For example, if you currently have version 1.5 RC4 installed you will need to download the 1.5 RC4 to 1.5 Stable patch package. The patch packages are available on <insert link to JoomlaCode here>. Each patch package is available in three different package formats. These are indicated by the file extension which is either .zip, .tar.gz or .tar.bz2. The contents of each of these alternative packages is identical so just choose the one most convenient for you.

For example, if you are upgrading from 1.5 RC4 to 1.5 Stable and you would prefer the .tar.gz package format, then select the file named Joomla_1.5RC4_to_1.5Stable-Patch_Package.tar.gz <Check the filename>.