Actions

Difference between revisions of "What are the minimum Joomla! requirements?"

From Joomla! Documentation

(New page: First you must have the base environment for Joomla!. We have thoroughly tested Joomla on: Linux, Free BSD, Mac OS X and Windows NT/2000/XP. Linux or one of the BSD's are recommended, but ...)
 
(Replaced content with a link to avoid duplication.)
Line 1: Line 1:
First you must have the base environment for Joomla!. We have thoroughly tested Joomla on: Linux, Free BSD, Mac OS X and Windows NT/2000/XP. Linux or one of the BSD's are recommended, but anything else that can run the 3 pieces of software listed below should do it.
+
Full details can be found in [http://www.joomla.org/about-joomla/technical-requirements.html Technical Requirements].
 
+
<noinclude>[[Category:FAQ]][[Category:Getting Started FAQ]][[Category:Installation FAQ]][[Category:Version 1.0 FAQ]][[Category:Version 1.5 FAQ]]</noinclude>
    * Apache: http://www.apache.org
+
    * MySQL: http://www.mysql.com
+
    * PHP '''1.0'''(version 4.1.2 or higher) '''1.5''' version 4.3 or higher: http://www.php.net
+
 
+
There are several bundled distributions of Apache/MySQL/PHP available at sourceforge.net
+
 
+
Server Configuration
+
 
+
You MUST ensure that PHP has been compiled with support for MySQL and Zlib in order to successfully run Joomla.
+
 
+
While we have reports that Joomla works on IIS server we recommend Apache for running Joomla on Windows.
+
 
+
Optional Components
+
 
+
If you want support for SEF URLs, you'll need mod_rewrite and the ability to use local .htaccess files.
+
 
+
[[Category:FAQ]]
+
[[Category:Getting Started FAQ]]
+
[[Category:Installation FAQ]]
+
[[Category:Version 1.5 FAQ]]
+

Revision as of 17:30, 17 November 2008

Full details can be found in Technical Requirements.