Actions

Difference between revisions of "What is "legacy mode"?"

From Joomla! Documentation

(New page: Legacy mode is a Plugin that can be activated by enabling the "System - Legacy" Plugin in the Plugin Manager. This Plugin emulates Joomla! 1.0 and allows many version 1.0 extensions to run...)
 
m (clean up categories with <noinclude> tags)
 
(One intermediate revision by one user not shown)
Line 1: Line 1:
 +
{{JVer|1.5}}<br />
 
Legacy mode is a Plugin that can be activated by enabling the "System - Legacy" Plugin in the Plugin Manager. This Plugin emulates Joomla! 1.0 and allows many version 1.0 extensions to run on Joomla! 1.5. There is a minimal performance decrease by this, but in most cases it is not significant.
 
Legacy mode is a Plugin that can be activated by enabling the "System - Legacy" Plugin in the Plugin Manager. This Plugin emulates Joomla! 1.0 and allows many version 1.0 extensions to run on Joomla! 1.5. There is a minimal performance decrease by this, but in most cases it is not significant.
  
Line 5: Line 6:
 
Legacy mode should be viewed as transitional software that allows you to work with version 1.0 extensions until the extension provider has reworked the extension to work with 1.5 in native mode.
 
Legacy mode should be viewed as transitional software that allows you to work with version 1.0 extensions until the extension provider has reworked the extension to work with 1.5 in native mode.
  
[[Category:FAQ]]
+
<noinclude>[[Category:FAQ]]
 
[[Category:Administration FAQ]]
 
[[Category:Administration FAQ]]
 
[[Category:Getting Started FAQ]]
 
[[Category:Getting Started FAQ]]
 
[[Category:Upgrading and Migrating FAQ]]
 
[[Category:Upgrading and Migrating FAQ]]
[[Category:Version 1.5 FAQ]]
+
[[Category:Version 1.5 FAQ]]</noinclude>

Latest revision as of 16:21, 1 September 2012

Joomla 1.5
Legacy mode is a Plugin that can be activated by enabling the "System - Legacy" Plugin in the Plugin Manager. This Plugin emulates Joomla! 1.0 and allows many version 1.0 extensions to run on Joomla! 1.5. There is a minimal performance decrease by this, but in most cases it is not significant.

Extension providers still need to test and certify that their 1.0 extensions work in legacy mode. This is indicated by the tab "1.5 Legacy" in the Joomla! Extensions Directory listing.

Legacy mode should be viewed as transitional software that allows you to work with version 1.0 extensions until the extension provider has reworked the extension to work with 1.5 in native mode.