Actions

Difference between revisions of "What version of Joomla! should you use?"

From Joomla! Documentation

(Remove text about 1.7 to 2.5 extension upgrades)
(Update to note 3.0 is now EOL)
Line 8: Line 8:
 
**{{JVer|1.7}} [[Joomla 1.7 version history]] (Version 1.7 reached end of life on 24 February 2012, support has ended.)
 
**{{JVer|1.7}} [[Joomla 1.7 version history]] (Version 1.7 reached end of life on 24 February 2012, support has ended.)
 
**{{JVer|2.5}} [[Joomla 2.5 version history]]
 
**{{JVer|2.5}} [[Joomla 2.5 version history]]
**{{JVer|3.0}} [[Joomla 3.0 version history]] (Version 3.0 will reach end of life on 24 May 2013.)
+
**{{JVer|3.0}} [[Joomla 3.0 version history]] (Version 3.0 reached end of life on 24 May 2013, support has ended.)
 
**{{JVer|3.1}} [[Joomla 3.1 version history]]
 
**{{JVer|3.1}} [[Joomla 3.1 version history]]
  

Revision as of 12:16, 28 May 2013

Normally, you should use the latest version of Joomla! for a new site unless you have a specific reason not to. The latest version can be downloaded from the Joomla! download site.

  • Make sure that you subscribe to the Joomla! Security Announcements feed. This forum is used to make announcements, including the availability of new releases, that could affect the security of your site.
  • If you are running an earlier release of the current version (for example, you are running 2.5.1 and the current version is 2.5.6), you should upgrade to the current version. Each minor release fixes a number of bugs and/or security issues. It is always good practice to upgrade to the latest minor version as a first step in troubleshooting a problem and fixing any newly discovered security issues.