Actions

Difference between revisions of "Will your 1.0 extensions still work?"

From Joomla! Documentation

(New page: There is a legacy system in place that will allow extensions that are not 1.5 compatible to continue to operate. However, we strongly recommend that you update to the current version of al...)
 
(Remove 1.6 and 1.7 tags)
(4 intermediate revisions by 3 users not shown)
Line 1: Line 1:
 +
= Joomla 2.5 and newer {{JVer|2.5}}{{JVer|3.x}} =
 +
 +
Extensions written for Joomla 1.0 will not work in Joomla 2.5 and newer. The legacy system used in Joomla 1.5 has been removed.
 +
 +
= Joomla 1.5 {{JVer|1.5}} =
 +
 
There is a legacy system in place that will allow extensions that are not 1.5 compatible to continue to operate. However, we strongly recommend that you update to the current version of all extensions prior to migration and that you check each extension's home page for specific recommendations about migration for that extension.
 
There is a legacy system in place that will allow extensions that are not 1.5 compatible to continue to operate. However, we strongly recommend that you update to the current version of all extensions prior to migration and that you check each extension's home page for specific recommendations about migration for that extension.
  
To activate the legacy support, go to the plugin manager and enable the legacy plugin.
+
To activate the legacy support, go to the [[Help15:Screen.plugins.15|Plugin Manager]] and enable the legacy plugin.
  
 +
<noinclude>
 
[[Category:Getting Started FAQ]]
 
[[Category:Getting Started FAQ]]
 +
[[Category:Installation FAQ]]
 
[[Category:Version 1.5 FAQ]]
 
[[Category:Version 1.5 FAQ]]
[[Category:Version 1.0 FAQ]]
+
[[Category:Version 2.5 FAQ]]
 +
</noinclude>

Revision as of 13:02, 29 April 2013

Joomla 2.5 and newer Joomla 2.5Joomla 3.x

Extensions written for Joomla 1.0 will not work in Joomla 2.5 and newer. The legacy system used in Joomla 1.5 has been removed.

Joomla 1.5 Joomla 1.5

There is a legacy system in place that will allow extensions that are not 1.5 compatible to continue to operate. However, we strongly recommend that you update to the current version of all extensions prior to migration and that you check each extension's home page for specific recommendations about migration for that extension.

To activate the legacy support, go to the Plugin Manager and enable the legacy plugin.