J2.5

Issues with the e-mail cloak and a use of PHP 5.3+

From Joomla! Documentation

The "J2.5" namespace is a namespace scheduled to be archived. This page contains information for a Joomla! version which is no longer supported. It exists only as a historical reference, it will not be improved and its content may be incomplete and/or contain broken links.

Display issues with the use of email cloaking when using PHP 5.3+

Errors reported

Parse error: syntax error, unexpected T_STATIC

Versions affected

Info non-talk.png
General Information

This pertains only to Joomla! version(s):- 2.5.23


What is the cause

Bug

How to fix

Update to the latest version of 2.5, which currently is 2.5.28.