J3.x

J3.x:Changes in language file loading


Other languages:
English • ‎français • ‎Nederlands

Errors reported

Because of how Joomla previously parsed the language INI files, it was possible for files with invalid syntax to be loaded without any errors raised. With a change in 3.7, these files may no longer load correctly.

Versions affected

General Information

This pertains only to Joomla! version: 3.7.0 and above

What is the cause

Since 3.7.0, the language file parser has been updated to use the PHP parse_ini_file function which will raise an error if invalid syntax is detected.

How to fix

Please fix the language strings to be correct and valid. You can check that by running the file against parse_ini_file e.g. using the command line or a PHP script.

Advertisement