J3.x

L'extension ne s'installe pas

From Joomla! Documentation

This page is a translated version of the page J3.x:Extension won't install and the translation is 100% complete.

Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎Nederlands • ‎русский • ‎中文(中国大陆)‎
Joomla! 
3.4.0

Certaines extensions ne s'installent pas sur Joomla! 3.4.0 générant une erreur "Aucun fichier sélectionné. Impossible de trouver le paquet d'installation"

Erreurs signalées

Aucun fichier sélectionné. Impossible de trouver le paquet d'installation.

(Notez que cette erreur est très générique et peut s'appliquer à nombre d'autres anomalies. C'est cependant la seule erreur UI indiquée comme raison de cette anomalie affectant UNIQUEMENT Joomla! 3.4.0)

Versions affectées

Info non-talk.png
General Information

This pertains only to Joomla! version(s):- 3.4.0

Quelle en est la cause

Des contrôles de sécurité supplémentaires pour les fichiers PHP ont été ajoutés aux téléchargements de fichier dans JFile::upload. Malheureusement, ceux-ci n'ont pas été désactivés pour l'installateur d'extensions, impliquant que tout fichier zip non compressé est interprété comme non fiable et n'est donc pas installé.

Comment solutionner cette anomalie

Assurez-vous que vos fichiers zip sont correctement compressés avant installation.

Appliquez le correctif suivant https://github.com/joomla/joomla-cms/pull/6180.patch (il sera ajouté à Joomla! 3.4.1)