J3.x

J3.x: Uppdatering misslyckas med ett felmeddelande

From Joomla! Documentation

This page is a translated version of the page J3.x:Update fails with an error message and the translation is 96% complete.

Other languages:
العربية • ‎Deutsch • ‎English • ‎español • ‎français • ‎magyar • ‎Bahasa Indonesia • ‎日本語 • ‎Nederlands • ‎svenska
Joomla! 
3.6.1

Fel som rapporteras

När du uppdatera din Joomla! hemsida till Joomla! 3.6.1 genom det inbyggda Joomla! Uppdateringstillägget, så visas följande felmeddelande: Joomla-3.6.1-error-message-en.png

Påverkade versioner

Allmän Information

Detta avser endast Joomla! version(er): "'3.6.1"'

Vad är orsaken?

I 3.6.1 införts en kontroll av CSRF-token till uppdateringenskomponenten som en extra nivå av säkerhet. Alla versioner från 3.6.0 ner till 2.5.4 (varje version med uppdateringskomponenten) kommer att få frågan med CSRF-token eftersom de versionerna inte genererar den nödvändiga koden för att klara kontrollen. Framtida uppdateringar kommer att fungera korrekt

Hur man fixar?

Uppdatering från Joomla! 3.6.0

  • Gå tillbaka till din administrationssida example.com/administrator
  • Gå sedan till Tillägg    Hantera    Databas
  • Du bör se ett meddelande om att dababasen är inaktuell
  • Klicka på Fix-knappen i verktygsfältet.

Uppdatering från Joomla! LÄGRE ÄN 3.6.0

Om du kör en version lägre än 3.6.0:

  • Update först till Joomla! 3.6.0 och "INTE" direkt till Joomla! 3.6.1
  • Uppdatera com_joomlaupdate via Tilläggshanteraren
  • Kör sedan uppdatering från Joomla! 3.6.0 till Joomla! 3.6.1.

Den nya versionen av com_joomlaupdate är tillgänglig i backend genom den vanliga uppdateringsfunktionen.

För mer information

Se också det officiella tillkännagivandet i samband med denna fråga HÄR

"OBS!"': Om din webbplats körs med PHP 5.3, kan detta felmeddelande visas när du försöker att logga in:
0 Misslyckades att starta sessionen: redan startad med PHP ($_SESSION är använd).
Joomla! 3.6.2 kommer att fixa det här problemet. Se Fix logging in in PHP 5.3.