J3.x

Mettre à jour vers Joomla 3.8.13 et 3.9.0 en tant que non Super Utilisateur

From Joomla! Documentation

This page is a translated version of the page J3.x:Updating to Joomla 3.8.13 and 3.9.0 as non-superuser and the translation is 100% complete.

Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎Nederlands • ‎русский • ‎svenska

Erreurs signalées

Lorsque vous lancez une mise à jour vers 3.8.13 ou 3.9.0+ à partir d'une version antérieure à 3.8.13 en tant que non super utilisateur, la mise à jour ne complète pas toutes les étapes requises et affiche un message "Vous n'êtes pas autorisé à voir cette ressource".

Versions affectées

Informations générales

Ceci ne concerne que les versions Joomla : 3.8.13 et supérieures

Quelle en est la cause

À partir de la version 3.8.13 et postérieures, le composant de mise à jour du noyau Joomla vérifie si vous êtes super utilisateur afin d'effectuer toute mise à jour du noyau. Comme sur toute version antérieure, cela est également possible pour certains non super utilisateurs avec les bonnes permissions.

Comment résoudre l'anomalie

Tout d'abord, faites vos mises à jour uniquement en tant que super utilisateur pour ne pas rencontrer ce problème.

  • Si vous rencontrez cette anomalie lors de la mise à jour vers 3.8.13, allez dans Extensions    Gérer    Base de données et cliquez sur le bouton Correction.
  • Lorsque vous ferez la mise à niveau vers Joomla 3.9.0 ou supérieur, veuillez également vérifier les extensions à installer dans Découvrir : Extensions    Gérer    Découvrir. Cliquez sur le bouton Découvrir, puis installez les extensions manquantes à l'aide du bouton Installer.