J3.x

Upgrade from 2.5 to 3.6.0 fails

Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎Nederlands
Joomla! 
3.6.0

Errors reported

If you want to upgrade from 2.5.28 to 3.6.0 you get errors like:

Notice: Undefined property: LoginController::$input in ...administrator\components\com_login\controller.php on line 36

Fatal error: Call to a member function set() on null in ...administrator\components\com_login\controller.php on line 36

Versions affected

General Information

This pertains only to Joomla! version(s): 3.6.0

What is the cause

If you upgrade from 2.5 to 3.6.0 we did not remove some old files that get now loaded before the new ones. This will be fixed with 3.6.1.

How to fix

Wait for 3.6.1 (released soon) or see: https://github.com/joomla/joomla-cms/pull/11282

Advertisement