Часто задаваемые вопросы по Joomla! 3

This page is a translated version of the page Joomla 3 FAQ and the translation is 100% complete.

Other languages:
العربية • ‎Deutsch • ‎English • ‎español • ‎فارسی • ‎français • ‎Bahasa Indonesia • ‎Nederlands • ‎português • ‎português do Brasil • ‎русский • ‎svenska • ‎ไทย

Contents

Каковы различия между Joomla! 2.5 и 3?

Наиболее заметное различие - это полностью измененный административный [интерфейс], который обновлен на современный дизайн со многими более простыми и более дружелюбными пользователю элементами. Также, начиная с версии 3.0, Joomla! теперь респонзивна [для мобильных] устройств. [Говоря] по-простому, Joomla! является дружелюбной мобильным [устройствам] и может быть использована на любом современном устройстве.

В дополнение, существуют дюжины мелких улучшений, [внесенных в] ядро Joomla!. Некоторые из них:

  • Новый установщик, который Вы заметите при создании новой установки Joomla! 3.x.
  • Joomal! 3 забита цацками для разработчиков расширений, таких как поддержка [библиотеки CSS] "Bootstrap" и [библиотеки JavaScript] "jQuery".

Joomla! 3.1

  • Метки

Joomla! 3.2

  • Контроль версий содержимого
  • Много улучшений интерфейса пользователя
  • Легкая настройка мульти-языковости с 64 официально поддерживаемыми языками
  • Встроенный поиск расширений Joomla! в качестве встроенного интерфейса [официального каталого расширений] "Joomla! Extensions Directory" (который в настоящее время перечисляет более шести тысячи расширений)
  • Укрепленная защита сильными паролями и двух-факторной аутентикацией
  • Новый фреймворк быстрой разработки для кодирования новых расширений

Joomla! 3.3

  • Микроданные

Joomla! 3.4

  • Редактирование модулей с лицевых страниц
  • Изъятие [компонента] com_weblinks
  • Интеграция с менеджером зависимостей РНР "Composer"
  • Интеграция с "No CAPTCHA reCAPTCHA" от Google
  • Стандартизация британского английского языка ядра

Joomla! 3.5

  • PHP 7 Support
  • Update Notifications via Email
  • System Information Export
  • Drag & Drop Images
  • Anonymised System Data
  • Easily Insert Modules in Articles
  • Item counter (+ click through filter) in Category Manager
  • Random category blog and list order view.

Joomla! 3.6

  • Show all menu items
  • Menu type ACL
  • Improved UX
  • Categories on the fly
  • Subform field
  • Improved Joomla! Updates
  • Allow stream connections to support proxies
  • Build more complex database queries with new database query classes
  • Delete all cache
  • Delete and rebuild Extension Update Sites
  • Easier template development with deeper JLayout integrations
  • htaccess authentication for calls
  • Improved Storage of dynamic JavaScript variables
  • Improved Validation performance
  • jQuery Update
  • More Extension Details in System info
  • Multilanguage ToS
  • New “Showon” Option for fieldsets in component config
  • New Log folder (for new installs only)
  • New positioning settings for Bootstrap tooltips extended
  • Protostar adds a new override for the Site Offline Page
  • Reverse Caching Support
  • SASS & SCSS File Support in Joomla! Template Manager
  • Updated version of the CodeMirror editor.

Joomla! 3.7

  • Custom Fields
  • Multilingual Associations Component
  • Article creation within the menu item
  • Backend Menu Manager
  • TinyMCE Improvements
  • Share sessions between backend and frontend
  • Allow packages to declare that their child extensions cannot be uninstalled
  • List of all new features



Как долго поддерживается каждая версия Joomla!?

Joomla! 
3.7.5
Стабильная версия

Эта страница предоставляет обзор текущей стратегии разработки, опубликованной 25-го апреля 2014 года. Все версии Joomla!, выпущенные до 25-го апреля 2014, были разработаны согласно предыдущего цикла выпусков и разработки. Для более подробной информации познакомтесь, пожалуйста, со стратегией разработки Joomla!.

Joomla! разрабатывается следуя семантическому версионированию (2.0.0). [Применяемые раньше термины] LTS (долгосрочная поддержка) и STS (краткосрочная поддержка) больше не действуют и не соблюдаются. Для ясности, [вместо них] используются термины, приведенные ниже. Вы должны понимать их и их значение.

  • поддерживается - самая последняя минорная версия(ии) мажорной версии, [которая] будет получать патчи, включающие исправления программных ошибок и патчи безопасности
  • текущая - самая молодая или самая последняя мажорная.x.x официально выпущенная версия
  • наследие - любая мажорная.минорная.патч версия(ии), которая не является текущей.[1]
  • стабильная - мажорная версия в отношении [версий со статусами] текущая и наследие, готовая для использования на производственных веб-сайтах.[2]
  • ОСП - сокращение от 'окончание срока поддержки', что означает что [для данной версии] больше не будет выпущено патчей с исправлениями программных ошибок и патчей безопасности
  • ОСЖ - сокращение от 'окончание срока жизни', что имеет то же значение что и 'окончание поддержки'.[3]

Каждая мажорная версия Joomla! поддерживается проектом Joomla!TM некоторое ограниченное время, начиная с даты ее официального выпуска. Проект Joomla! будет активно разрабатывать каждую мажорную версию как минимум в течении двух лет. За этим может последовать продолжение разработки мажорной версии согласно плана разработки мажорной версии.[4].

Вкратце можно сказать так:

  • каждая мажорная версия будет поддерживаться как минимум 4 года
  • Вам всегда необходимо использовать наипоследнюю версию минорная.патч наипоследней мажорной версии или обновиться на нее
  • каждая выпущенная минорная версия является обратно совместимой с предыдущим минорным выпуском[5]

Для определения приблизительной даты окончания срока поддержки каждой версии(ий) мажорная.минорная или всей мажорной версии, используйте, пожалуйста, маршрут разработки Joomla! CMS или версии Joomla! CMS.

Объяснение нумерации версий

Идентификаторы версий Joomla! соблюдают трех уровневую нумерную конвенцию, где данные уровни определяются значением [примененного в] системе изменения.

[major].[minor].[patch]

Эти 3 уровня определяются следующим образом:

  1. Инкрементное увеличение номера идентификатора мажорной версии указывает на разрыв в обратной совместимости.
  2. Инкрементное увеличение номера идентификатора минорной версии указывает добавление новых характеристик или значительное изменение существующих.
  3. Инкрементное увеличение номера идентификатора версии патч указывает на устранение каких-либо программных ошибок.

Примеры

Вы используете версию Joomla! 3.3.6. Это означает, что Ваша версия - мажорная версия 3, минорная версия 3, патч версия 6. Если для версии 3.3.6 будет выпущен какой-либо патч, то он увеличит версию Joomla! на 3.3.7. Если для мажорной версии 3 выпущена новая минорная версия, то версия Вашей Joomla! станет 3.4.0. Эта страница будет всегда показывать в правом верхнем углу текущую стабильную поддерживаемую версию Joomla!, включая минорную и патч.


Я создаю совершенно новый веб-сайт. Следует ли мне запускать сайт на Joomla! 2.5 или Joomla! 3.x?

Joomla 2.5 достигла окончания срока поддержики 31-го декабря 2014 года. Это означает, что начиная с этого дня [система] больше не получит дальнейшего внимания или поддержки со стороны [команды] проекта Joomla!. Больше не будет [выпущено] ни выпусков обслуживания, ни выпусков безопасности. Так что Вам не следует начинать новый веб-сайт на Joomla! 2.5, но всегда - на Joomla! 3.3 или более новых [версиях].

Sites that are currently on Joomla! 2.5 are encouraged to start planning now for a migration to 3.3 or greater now. We’ve provided a one-click upgrade from Joomla! 2.5 to any Joomla! 3 version and you just have to make sure that all your extensions and template are compatible with Joomla! 3.x before upgrading. See Planning for Mini-Migration - Joomla 2.5 to 3.x (See the “How do I find Joomla 3.x compatible extensions?” FAQ below for more information)

Смотрите также: Зачем мигрировать и все относящиеся к этому страницы.


Если я запущу веб-сайт на Joomla! 3, смогу ли устанавливать расширения?

Да, Вы сможете устанавливать расширения, совместимые с Joomla! 3.х. Официальный каталог расширений "Joomla! Extensions Directory™" (JED) имеет иконку совместимости [расширений с] Joomla 3.x, [при показе которой Вы будете] знать какие расширения совместимы с Joomla 3.x. Однако, лучше всего будет свериться [об этом] на веб-сайте самого разработчика [конкретного расширения].


Как мне получить шаблон для Joomla! 3.x?

Template companies are offering Joomla! 3 templates at present, taking advantage of Joomla! 3's responsive design. Also, please note that some Joomla! 2.5 templates will work in Joomla! 3 without any issues or any changes needed, but some will not. It's best to consult with the template's developer on this.


Как мне найти расширения, совместимые с Joomla! 3.x?

Посетите официальный каталог расширений "Joomla! Extensions Directory™" (JED), [на страницах] которого Вы увидите иконку совместимости [представленных расширений] с Joomla 3.0, что укажет Вам на расширения, совместимые с Joomla 3.x; однако, лучше всего проверить это на веб-сайте разработчика конкретного расширения.


Будут ли мои расширения, [работавшие на] Joomla! 2.5, работать с Joomla 3.x?

Joomla! 
3.x
серия

Собственные расширения Joomla! 2.5 должны работать с Joomla! 3.0 с очень небольшими изменениями, если они вообще будут нужны. Больше всего будет необходимо поработать над компонентами и шаблонами, в то время как модули и плагины должны работать без проблем (при условии, что они не используют устаревшием методы [программирования]). Расширения, один и тот же пакет которых поддерживает как Joomla! 2.5, так и Joomla! 1.5, скорее всего сразу работать не будут и будут нуждаться в обновлении своими разработчиками для совместимости с Joomla! 3.

Вкратце, это зависит от данного расширения. Проект Joomla! сделал этот процесс для некоторых расширения относительно легким, однако для некоторых других расширении будет необходимо потрудиться. Для полной ясности, свяжитесь с разработчиком нужного расширения и дайте ему знать о том, что Вы желаете использовать его расширение с Joomla! 3. Также проконсультируйтесь с его документацией.


Что произойдет, если я запущу сайт на Joomla! 3.x, но необходимые мне расширения [совместимы только с] Joomla! 2.5?

Вам необходимо спросить разработчика данного расширения имеются ли у них планы в ближайшем будущем выпустить данное расширение для Joomla! 3. Разработчикам действительно необходимо вносить [в свое расширение] некоторые изменения [для его совместимости с Joomla! 3], но насколько они обширны, зависит от самого расширения.


Следует ли мне обновиться с Joomla! 2.5 на Joomla! 3.x?

В большинстве случаев, Вам нужно будет начать планирование перехода на Joomla! 3.x как можно скорее. Joomla! 2.5 достигла окончания срока поддержки по состоянию на 31 декабря 2014 года. Joomla 3 стабильна и должна быть выбрана для производственных веб-сайтов.

Перед переходом удостоверьтесь в том, что Ваши компоненты и шаблоны совместимы с Joomla! 3.x. Все компоненты ядра уже готовы к этому обновлению.

Познакомтесь, пожалуйста, с документом Зачем мигрировать для более подробной информации по миграции с 2.5 на 3.x.


У меня имеется веб-сайт на 2.5 и я вижу, что менеджер обновлений разрешает мне переход на 3.х; если он это разрешает - должен ли я [делать это]?

Не делайте этого если Вы не уверены на 1000%. По умолчанию Joomla! не позволит Вам обновиться на 3.х до тех пор, пока в компоненте обновления Joomla! Вы не включите следующую опцию: "Компоненты" -> "Обновление Joomla!" -> "Настройки" -> "Сервер обновления" -> "Дистрибутивы Joomla! с краткосрочной поддержкой". Если по какой-либо причине Вы изменили эту опцию и хотели бы, чтобы компонент обновления не разрешал Вам обновляться, измените эту опцию на "Дистрибутивы Joomla! с длительным сроком поддержки (рекомендуется)". После внесения этого изменения Вы будете получать только [сообщения о наличии новых версий серии] 2.5.

Примечание: Вам не следует обновляться с Joomla! 2.5 на Joomla! 3.x до тех пор, пока Вы не уверены в том, что все установленные Вами дополнительные расширения (от сторонних разработчиков), особенно шаблоны, готовы к Joomla! 3.x или что у них имеется версия для Joomla! 3.x, на которую Вы можете обновиться. Вы должны переходить с 2.5 на 3.х не на своем производственном сайте, но на испытательном сайте для разработок. Познакомтесь с документом Зачем мигрировать и пройдитесь по страницам с подробной информацией о переходе с 2.5 на 3.х.


Что следует после Joomla! 3.0?

Joomla! 3.1, 3.2, 3.3, 3.4 и так далее. Новая стратегия разработки Joomla! объявлена здесь. Для более подробной информации, загляните, пожалуйста на эту страницу с полным текстом стратегии разработки.

Короткое напоминание: если Вы используете любую версию Joomla!, за исключением Joomla! 3.7.5, Вам следует подумать над обновлением этой версии или мигрированием как можно скорее! Долгосрочных версий с нумерацией .5 больше не будет [выпущено]. Самая последняя версия Joomla! - это долгосрочная версия. Для списка текущих и будущих выпусков просмотрите [эту страницу с] версиями Joomla! CMS.

Joomla! 1.5 не поддерживается, [начиная] с окончания 2012 года и Joomla! 2.5 [достигла статуса] EOS (окончание поддержки) начиная с 31 декабря 2014 года. [Говоря] по-простому, Вам следует использовать Joomla! 3.7.5.


Хорошо, я готов и желаю обновиться. Как мне обновиться?

  • Во-первых, изучите технические требования по Joomla! 3.x и удостоверьтесь в [том], что Ваша серверная среда выполняет эти требования.
  • Во-вторых, удостоверьтесь в том, что все Ваши расширения (особенно Ваш шаблон), совместимы с Joomla! 3.x.
  • В-третьих, создайте какой-либо испытательный веб-сайт и протестируйте данный переход сначала на этом испытательном веб-сайте.
  • В-четвертных, если у Вас по какому-либо поводу возникают сомнения, проконсультируйтесь у доверенного разработчика.
  • В-пятых, создайте полную резервную копию (файлов и базы данных) своего веб-сайта.

Как только готовы, пройдите на компонент обновления Joomla!: Компоненты > Обновление Joomla! Щелкните на [находящуюся в провом верхнем углу кнопку] "Настройки" и измените [параметр "Сервер обновления"] на [опцию] "Дистрибутивы Joomla! с краткосрочной поддержкой". [Нажмите на кнопку] "Сохранить". [В ответ] Вы должны увидеть сообщение о наличии Joomla 3.x. Щелкните по кнопке для установки [более новой версии системы]. Очистите кэш своего браузера, чтобы Вы смогли увидеть внесенные изменения. Вот и все!

В заключение, проведите двойную проверку и удостоверьтесь в том, что все работает надлежащим образом.

Смотрите Планирование мини-миграции - с Joomla! 2.5 на 3.x и Миграция с Joomla! 2.5 на 3.x шаг за шагом для более подробных инструкций.

Примечание: на некоторых хостерах Вам, возможно, придется задействовать какой-либо альтернативный метод обновления, [например] такой, как использование установщика расширений.


Но что, если я на Joomla! 1.5? Будет ли мой сайт нарушен? Мне переходить на 2.5 или на текущую версию [семьи версий] 3.х?

Хорошо, последний вопрос. Где мне получить больше информации о Joomla! 3?

Вы можете найти больше информации на странице http://www.joomla.org/3.


Мы надеемся Вы порадовались Joomla! 3 также как и мы! Благодарим за чтение этих часто задаваемых вопросов.

Ссылки

  1. Учтите, что наследие - это термин, который используется только для обозначение статуса какой-либо версии в отношении версии, текущей [на данный момент]. Для определения целесообразности использования какой-либо версии [со статусом] наследие пользователи и разработчики должны внимательно рассмотреть дату(ы) окончания срока ее поддержки.
  2. Версии, отмеченные как Альфа, Бета или RC, необходимо использовать только для тестирования
  3. 'ОСП' и 'ОСЖ' можно использовать как взаимо заменяемые термины. Любой [из этих двух терминов] означет 'окончание срока поддержки', не более того. Не принимайте 'окончание срока жизни' [данной версии] как [термин, означающий что начиная с данной даты] данная версия перестанет работать.
  4. Полное объяснение поддерживаемых выпусков можно найти под заголовком 'Поддерживаемые выпуски 4.3' на странице документа стратегии разработки Joomla!
  5. Какое-либо расширение или шаблон, установленные на версии минорная.0.х, будут работать на версии мажорная.7.х. Не принадлежащие ядру Joomla расширения или шаблоны разрабатываются сторонними разработчиками и обновление и публикация обновлений сторонних расширений и шаблонов - ответственность их разработчиков. Установка обновления какого-либо расширения или шаблона - ответственность используемого это расширение или шаблон пользователя.
Advertisement