Actions

Joomla 3 FAQ/sv

This page is a translated version of a page Joomla 3 FAQ and the translation is 38% complete.

Other languages:
العربية 100% • ‎Deutsch 100% • ‎English 100% • ‎español 100% • ‎فارسی 3% • ‎français 100% • ‎Nederlands 100% • ‎português 100% • ‎português do Brasil 100% • ‎русский 100% • ‎svenska 38% • ‎ไทย 56%

Vad är skillnaden mellan Joomla! 2.5 och 3?

What are the major differences between Joomla! 2.5 and 3.x?/sv

Hur länge stöds varje Joomla!-version?

Release and support cycle/sv

Jag bygger en helt ny webbplats. Skall jag använda Joomla! 2.5 eller 3.x?

Should I launch a Joomla! 2.5 site or a 3.x site?/sv

Om jag startar Joomla! 3 på min webbplats, kommer jag då att kunna installera tillägg?

If I launch a Joomla! 3 site, will I be able to install extensions?/sv

Hur får jag tag på en sidmall till Joomla! 3?

How do I get a Joomla! 3.x template?/sv

Hur hittar jag tillägg som är kompatibla med Joomla! 3?

How do I find Joomla! 3.x compatible extensions?/sv

Will my Joomla! 2.5 extensions work with Joomla! 3.x?

Joomla! 
3.x
series

Extensions that are native to Joomla! 2.5 should work on Joomla! 3.0 with very little change, if any. Components and templates will need the most work, while modules and plugins should work without issue (assuming they do not use deprecated methods). Extensions that support Joomla! 2.5 and 1.5 in the same package will likely not work right away, until the developers update them for Joomla! 3 compatibility.

In short, it depends on the extension. The Joomla! Project has made the process relatively easy for most extensions, however for some extensions it’s going to take some work. To be certain, let the developers of the extensions know that you want to use their extension on Joomla 3 and consult with their documentation.


What happens if I launch a Joomla! 3.x site, but the extension I want is for a 2.5 site?

You need to speak with the extension developer to see if they have plans to release that extension for Joomla! 3 in the immediate future. Developers do have to make some changes but how extensive they are depends on the extension.


Should I update from Joomla! 2.5 to 3.x?

In most cases, you will need to start planning on an upgrade to Joomla! 3.x ASAP. Joomla! 2.5 has reached EOS (end of support) as of December 31st of 2014. Joomla 3 is stable and should be the choice for production sites.

You will need to verify your template and components will work with Joomla! 3.x before upgrading. All core components are upgrade ready right now.

Please see Why Migrate for more details on migration from 2.5 to 3.x.


I have a 2.5 site and I see a that the Joomla! update manager lets me upgrade to 3.x; should I do it since it’s letting me?

Not unless you’re 1000% sure. By default, Joomla will not let you update to 3.x unless you activate the option within the Joomla! Update component (administrator >> Component >> Joomla! Update >> Options >> Update server >> Short Term Support). If for some reason you’ve changed this, and you’d like the updater to stop letting you upgrade, change the setting to Long Term Support. After making this change, you’ll only receive updates for Joomla! 2.5.

Notice: You should not upgrade from Joomla! 2.5 to Joomla! 3.x unless you are certain that all of your additionally installed extensions (from third party developers), especially templates, are Joomla! 3.x ready or have a Joomla! 3.x version that you can upgrade to. You should only upgrade from 2.5 to 3.x on a development site not on your live site. See Why Migrate and follow the pages for more information on upgrading from 2.5 to 3.x.


What’s next after Joomla 3.0?

Joomla! 3.1, 3.2, 3.3, 3.4 and more. Joomla's new development strategy is announced here, please read the full text of the development strategy for more information.

A quick summary, if you are using any version of Joomla! except Joomla 3.7.2, you should consider updating or migrating ASAP! There will no longer be a Long Term Support Version with a .5 designation. The latest version of Joomla is the Long Term Support Version. See Joomla! CMS versions for a listing of current and future releases.

Joomla! 1.5 has not been supported for since the end of 2012 and Joomla! 2.5 is EOS (end of support) since 31 Dec 2014. Simply, you should be using Joomla! 3.7.2.


Okay, I’m ready and want to upgrade. How do I do the upgrade?

  • First, review the system requirements for Joomla! 3.x and make sure that your server environment meets those requirements.
  • Second, make sure that all your extensions (especially, your templates) are Joomla 3.x compatible.
  • Third, create a test site and test the upgrade on the test site first.
  • Fourth, consult a trusted developer if you’re not 100% certain about anything.
  • Fifth, make a full backup of your site (files and database).

Once ready, go to the Joomla! Update component. Click on options and change the setting to Short Term Support. Save. You should be notified of the availability of Joomla! 3.x. Click the button to install. Clear your browser’s cache to make sure you see the latest changes. That’s it!

Finally, double check and make sure that everything is working properly.

See Planning for Mini-Migration - Joomla! 2.5 to 3.x and Joomla! 2.5 to 3.x Step by Step Migration for detailed instructions.

Note: On some hosts you may need to use alternative update methods such as using the extensions installer.


But what if I’m on Joomla 1.5. Will my site break? Do I migrate to 2.5 or the current version of 3?

OK, final question. Where can I get more information about Joomla 3?

You can get more information at http://www.joomla.org/3.


We hope you enjoy Joomla 3 as much as we do! Thanks for reading this FAQ.

References

Advertisement