Library/it

From Joomla! Documentation

This page is a translated version of the page Library and the translation is 29% complete.

Other languages:
Deutsch • ‎English • ‎español • ‎eesti • ‎français • ‎italiano • ‎Nederlands • ‎português

A library is a package of code which provides a related group of functions. Some external libraries are included and used by the Joomla! Framework or Extensions included in a default installation of Joomla! Please see below a reference of included external libraries.

Starting with Joomla 1.6, external libraries may be installed, updated and deleted using the extension installer. This makes Joomla! flexible for Extension Developers because it also allows the developers to include libraries for use by their component, module, plugin or template.


Included External Libraries

Una installazione di Joomla! contiene librerie esterne che sono incluse nel CMS di Joomla!. Queste librerie esterne non fanno parte del codice di base. Si prega di leggere la sezione Note in quanto potrebbero contenere più informazioni, come ad esempio un cambio di versione libreria esterna rilasciato con una versione di manutenzione.

Joomla! 
3.9.24
Stable Version

Librerie esterne di Joomla

Versione del CMS Versione del CMS Supportata Mootools Mootools More jQuery jQuery UI
(Core, Widget, Mouse, Posizione e Ordinamento)
Bootstrap Simple Pie PHP Mailer PHP UTF-8 IDNA Convert Framework per lo sviluppo rapido di Applicazioni (RAD)
Framework di Akeeba (FOF)
password_compat[1] lessphp password_compat[2]
3.9
Checkmark.png
1.4.5 1.4.0.1 1.12.4[3] 1.9.2 2.3.2[4] 1.3.1[5] 5.2.26 0.5 0.8.0 2.4.3 1.0.4 0.5.0 1.4.1
3.8
X-mark.png
1.4.5 1.4.0.1 1.12.4[3] 1.9.2 2.3.2[4] 1.3.1[5] 5.2.24[6] 0.5 0.8.0 2.4.3 1.0.4 0.5.0 1.4.1
3.7
X-mark.png
1.4.5 1.4.0.1 1.12.4[3] 1.9.2 2.3.2[4] 1.3.1[5] 5.2.22[7] 0.5 0.8.0 2.4.3 1.0.4 0.5.0 1.4.1
3.6
X-mark.png
1.4.5 1.4.0.1 1.12.4[3] 1.9.2 2.3.2[4] 1.3.1[5] 5.2.14[8] 0.5 0.8.0 2.4.3 1.0.4 0.5.0 1.4.1
3.5
X-mark.png
1.4.5 1.4.0.1 1.11.3[3] 1.9.2 2.3.2[4] 1.2[5] 5.2.14 0.5 0.8.0 2.4.3 1.0.4 0.5.0 1.0.10
3.4
X-mark.png
1.4.5 1.4.0.1 1.11.3[3] 1.9.2 2.3.2[4] 1.2[5] 5.2.9 0.5 0.8.0 2.4.3 1.0.4 0.3.9 N/A[9]
3.3
X-mark.png
1.4.5 1.4.0.1 1.11.1[3] 1.9.2 2.3.2[4] 1.2[5] 5.2.8 0.5 0.8.0 2.1 1.0.3 N/A[10] N/A[9]
3.2
X-mark.png
1.4.5 1.4.0.1 1.10.2[3] 1.9.2 2.3.2[4] 1.2[5] 5.2.6 0.5 0.8.0 2.1 1.0.3 N/A[10] N/A[9]
3.1.2
X-mark.png
1.4.5 1.4.0.1 1.8.3 1.8.23 2.3.2[4] 1.2[5] 5.2.6 0.5 0.8.0 N/A[11] N/A[12] N/A[10] N/A[9]
3.1
X-mark.png
1.4.5 1.4.0.1 1.8.3 1.8.23 2.1.0 1.2[5] 5.2.3 0.5 N/A[13] N/A[11] N/A[12] N/A[10] N/A[9]
3.0
X-mark.png
1.4.5 1.4.0.1 1.8.1 1.8.23 2.1.0 1.2 5.2.1 0.5 N/A[13] N/A[11] N/A[12] N/A[10] N/A[9]
2.5
X-mark.png
1.4.5[14] 1.4.0.1 N/A[15] N/A[15] N/A[15] 1.2 5.2.1 0.5 N/A[13] N/A[11] N/A[12] N/A[10] N/A[9]


References

  1. Questa libreria serve a fornire la compatibilità con le funzioni password_* che sono state aggiunte a PHP 5.5. Per ulteriori informazioni vedere password_compat git.
  2. Questa libreria serve a fornire la compatibilità con le funzioni random_bytes e random_int che sono state aggiunte a PHP 7.0. Per ulteriori informazioni vedere random_compat git.
  3. 3.0 3.1 3.2 3.3 3.4 3.5 3.6 3.7 Include il plugin jQuery Migrate versione 1.2.1 per la compatibilità all'indietro
  4. 4.0 4.1 4.2 4.3 4.4 4.5 4.6 4.7 4.8 Contiene alcune compatibilità con la 2.1
  5. 5.0 5.1 5.2 5.3 5.4 5.5 5.6 5.7 5.8 5.9 Questa libreria è stata deprecata per JFeedFactory nel CMS Joomla! versione 3.1.0
  6. 5.2.26 as of 3.8.3
  7. 5.2.23 as of 3.7.3
  8. 5.2.16 as of 3.6.3
  9. 9.0 9.1 9.2 9.3 9.4 9.5 9.6 Non applicabile, questa libreria non è stata inclusa nelle versioni precedenti alla 3.5 del CMS Joomla!
  10. 10.0 10.1 10.2 10.3 10.4 10.5 Non applicabile, questa libreria non è stata inclusa nelle versioni precedenti alla 3.4 del CMS Joomla!
  11. 11.0 11.1 11.2 11.3 Non applicabile, questa libreria non è stata inclusa nelle versioni precedenti alla 3.2 del CMS Joomla!. La versione di FOF incluso in Joomla 3.2 è compatibile con Joomla 2.5.
  12. 12.0 12.1 12.2 12.3 Non applicabile,questa libreria non è stata inclusa nelle versioni precedenti alla 3.2 del CMS Joomla!
  13. 13.0 13.1 13.2 Non applicabile, questa libreria non è stata inclusa nelle versioni precedenti alla 3.1.2 del CMS Joomla!
  14. Contiene un livello 1.2 di compatibilità
  15. 15.0 15.1 15.2 Non applicabile, questa libreria non è stata inclusa nella versione 2.5 del CMS Joomla!.