Requisitos técnicos opcionales

From Joomla! Documentation

This page is a translated version of the page Optional Technical Requirements and the translation is 100% complete.

Other languages:
Deutsch • ‎English • ‎español • ‎فارسی • ‎français • ‎italiano • ‎Nederlands • ‎português

Subrequisitos para Joomla! 3.x

En esta página se encuentran los requisitos técnicos opcionales que no son obligatorios para que Joomla! pueda ser instalado y funcione, pero son requeridos por algunas dependencias que utilizan diferentes API internas.


Aplicación
JApplicationDaemon Requiere ext/pcntl y ext/posix de PHP
Archivo
BZ2 Requiere ext/bz2 de PHP
GZip Requiere ext/zlib de PHP
Zip Requiere ext/zip o ext/zlib de PHP
Caché
APC Requires ext/apc en PHP 5.3 o 5.4, ext/apcu en PHP 5.5 o 5.6, no es compatible con PHP 7.x (Nota: ESTO DEBE SER VERIFICADO)
APCu Requiere ext/apcu en PHP 5.3+
CacheLite Requiere el paquete PEAR Cache_Lite (probado en 1.7.16, funcionará con 1.8)
Memcache Requiere ext/memcache de PHP y un servidor de Memcache
Memcached Requiere ext/memcached de PHP y un servidor de Memcached
Redis Requiere ext/redis de PHP y un servidor Redis
Wincache Requiere ext/wincache de PHP (solo en Windows)
XCache Requiere ext/xcache de PHP
Adaptadores de cliente
LDAP Requiere ext/ldap de PHP
HTTP/Curl Requiere ext/curl de PHP
HTTP/Socket Requiere que la función fsockopen() de PHP esté activada
HTTP/Stream Requiere que las función fopen() y allow_url_fopen de PHP estén activados
Criptografía
JCrypt Requiere ext/mcrypt de PHP
JKeychain Requiere ext/openssl de PHP
Base de datos
Microsoft SQL Azure Requiere ext/sqlsrv de PHP (solo en Windows)
Microsoft SQL Server Requiere ext/sqlsrv de PHP (solo en Windows)
MySQL Requiere ext/mysql de PHP (no compatible con PHP 7.x)
MySQLi Requiere ext/mysqli de PHP
Oracle Requiere ext/mysql de PHP con soporte para Oracle (disponible solo para 3PD, el CMS no funcionará con él)
PDO MySQL Requiere ext/pdo de PHP con soporte para MySQL
PostgreSQL Requiere ext/pgsql de PHP
SQLite Requiere ext/pdo de PHP con soporte para SQLite (disponible solo para 3PD, el CMS no funcionará con él)
Imagen
Requiere ext/gd de PHP
Sesión
APC Requires ext/apc en PHP 5.3 o 5.4, ext/apcu en PHP 5.5 o 5.6, no es compatible con PHP 7.x (Nota: ESTO DEBE SER VERIFICADO)
Memcache Requiere ext/memcache de PHP y un servidor de Memcache
Memcached Requiere ext/memcached de PHP y un servidor de Memcached
Wincache Requiere ext/wincache de PHP (solo en Windows)
XCache Requiere ext/xcache de PHP
Mejoras opcionales
Cadena
Activar ext/mbstring de PHP para la biblioteca phputf8 para usar las funciones nativas