Exigences techniques optionnelles

From Joomla! Documentation

This page is a translated version of the page Optional Technical Requirements and the translation is 100% complete.

Other languages:
Deutsch • ‎English • ‎español • ‎فارسی • ‎français • ‎Nederlands • ‎português

Sous-exigences pour Joomla! 3.x

Cette page donne la liste des exigences techniques facultatives qui ne sont pas requises pour pouvoir installer et utiliser Joomla! mais qui sont nécessaires pour que certaines dépendances puissent exécuter différentes API internes.


Application
JApplicationDaemon Nécessite PHP ext/pcntl et ext/posix
Archive
BZ2 Nécessite PHP ext/bz2
GZip Nécessite PHP ext/zlib
Zip Nécessite PHP ext/zip et ext/zlib
Cache
APC Nécessite PHP ext/apc pour PHP 5.3 ou 5.4, ext/apcu pour PHP 5.5 ou 5.6, non pris en charge pour PHP 7.x (Note : CECI DOIT ÊTRE VÉRIFIÉ)
APCu Nécessite PHP ext/apcu pour PHP 5.3+
CacheLite Nécessite le pack PEAR Cache_Lite (testé sur 1.7.16, fonctionne with 1.8)
Memcache Nécessite PHP ext/memcache et un serveur Memcache (Remarque : l'extension Memcache n'est pas compatible avec PHP 7.x)
Memcached Nécessite PHP ext/memcached et un serveur Memcached
Redis Nécessite PHP ext/redis et un serveur Redis
Wincache Nécessite PHP ext/wincache (uniquement pour Windows)
XCache Nécessite PHP ext/xcache
Adaptateurs clients
LDAP Nécessite PHP ext/ldap
HTTP/Curl Nécessite PHP ext/curl
HTTP/Socket Nécessite PHP fsockopen() fonction activée
HTTP/Stream Nécessite que la fonction PHP fopen() et allow_url_fopen soient activés
Cryptographie
JCrypt Nécessite PHP ext/mcrypt pour le chiffrage à l'exception de SodiumCipher qui nécessite ext/sodium
JKeychain Nécessite PHP ext/openssl
Base de données
Microsoft SQL Azure Nécessite PHP ext/sqlsrv (l'extension PHP 5.x supporte uniquement Windows, une version de l'extension compatible Linux est disponible avec PHP 7.x)
Microsoft SQL Server Nécessite PHP ext/sqlsrv (the PHP 5.x extension only supports Windows, a Linux compatible version of the extension is available for PHP 7.x)
MySQL Nécessite PHP ext/mysql (non supporté dans PHP 7.x)
MySQLi Nécessite PHP ext/mysqli
Oracle Nécessite PHP ext/pdo avec le support Oracle (disponible uniquement pour 3PD ; le CMS ne fonctionnera pas sans cela)
PDO MySQL Nécessite PHP ext/pdo avec le support MySQL
PostgreSQL Nécessite PHP ext/pgsql
SQLite Nécessite PHP ext/pdo avec le support SQLite (disponible uniquement avec 3PD ; le CMS ne fonctionnera pas sans cela)
Image
Nécessite PHP ext/gd
Session
APC Nécessite PHP ext/apc pour PHP 5.3 ou 5.4, ext/apcu pour PHP 5.5 ou 5.6, non pris en charge pour PHP 7.x (Note : CECI DOIT ÊTRE VÉRIFIÉ)
Memcache Nécessite PHP ext/memcache et un serveur Memcache (Remarque : l'extension Memcache n'est pas compatible avec PHP 7.x)
Memcached Nécessite PHP ext/memcached et un serveur Memcached
Wincache Nécessite PHP ext/wincache (uniquement pour Windows)
XCache Nécessite PHP ext/xcache
AMÉLIORATIONS OPTIONNELLES
Chaîne de caractère
Activez PHP ext/mbstring pour la librairie phputf8 pour utiliser les fonctions natives