Should I update from Joomla! 2.5 to 3.x?

Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎Bahasa Indonesia • ‎Nederlands • ‎português • ‎русский

In most cases, you will need to start planning on an upgrade to Joomla! 3.x ASAP. Joomla! 2.5 has reached EOS (end of support) as of December 31st of 2014. Joomla 3 is stable and should be the choice for production sites.

You will need to verify your template and components will work with Joomla! 3.x before upgrading. All core components are upgrade ready right now.

Please see Why Migrate for more details on migration from 2.5 to 3.x.

Advertisement