Technische Anforderungen

This page is a translated version of the page Technical requirements and the translation is 86% complete.

Other languages:
العربية • ‎Deutsch • ‎English • ‎español • ‎eesti • ‎فارسی • ‎français • ‎Bahasa Indonesia • ‎italiano • ‎Nederlands • ‎português • ‎português do Brasil • ‎русский • ‎中文(台灣)‎

More details can be found on the Joomla! Downloads Portal.

Joomla! 
3.x

Anforderungen für unterstützte Software

Voraussetzungen für Joomla 3.x Joomla 3.x

Software Empfohlen Minimum Mehr Informationen
PHP (Magic Quotes GPC, MB String Overload = off / Zlib Compression Support, XML Support, INI Parser Support, JSON Support, Mcrypt Support, MB Language = Default) 5.6 + oder 7 +[1] 5.3.10 + www.php.net
Unterstützte Datenbanken:
MySQL[2] (InnoDB Support erforderlich) 5.5.3 + 5.1 + www.mysql.com
SQL Server 10.50.1600.1 + 10.50.1600.1 + www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 + www.postgresql.org
Unterstützte Web-Server:
Apache(mit mod_mysql, mod_xml, und mod_zlib)[3][4] 2.4 + 2.x + www.apache.org
Nginx 1.8 + 1.0 + wiki.nginx.org
Microsoft IIS 7 7 www.iis.net


Referenzen

  1. PHP 5.3.1 ist erforderlich für die Versionen 3.0 bis 3.2. Ab Version 3.3 ist mindestens PHP 5.3.10 nötig.
    Nur Joomla! Versionen 3.5 und höher sind mit PHP 7 kompatibel.
  2. Joomla ist noch nicht kompatibel mit MySQL 6.x.
  3. Um Suchmaschinenfreundliche URLs einzusetzen, muss die Apache mod_rewrite-Erweiterung installiert sein.
  4. Die mod_suphp Erweiterung oder mod_fcgid - Erweiterung wird empfohlen damit Joomla Dateien hochladen und mit sicheren Datei-Berechtigungen ausführen kann.

Optional Requirements for Joomla! 3.x

Some optional technical requirements aren't required to install and run Joomla! but are required for some dependencies running different internal APIs.

Advertisement