Actions

Technical requirements

From Joomla! Documentation

This page is a translated version of the page Technical requirements and the translation is 100% complete.

Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎Nederlands

More details can be found on Joomla.org.

Joomla 3.x Joomla 3.x

Software Recommended Minimum
PHP (Magic Quotes GPC off) 5.5 + 5.3.10 +
Supported Databases:
MySQL[1] (InnoDB support required) 5.1 + 5.1 +
MSSQL 10.50.1600.1 + 10.50.1600.1 +
PostgreSQL 8.3.18 + 8.3.18 +
Supported Web Servers:
Apache(with mod_mysql, mod_xml, and mod_zlib)[2][3] 2.x+ 2.x+
Hiawatha (with UrlToolkit support) latest 8.0
Nginx 1.1 1.0
Microsoft IIS 7 7


References

  1. Joomla is not yet compatible with MySQL 6.x.
  2. In order to use Search Engine Friendly URLs, you will need to have the Apache mod_rewrite extension installed.
  3. The mod_suphp extension or mod_fcgid extension is recommended to enable Joomla to upload and execute files using secure file permissions.