Requisitos técnicos

From Joomla! Documentation

This page is a translated version of the page Technical requirements and the translation is 100% complete.

Other languages:
العربية • ‎Deutsch • ‎English • ‎español • ‎eesti • ‎فارسی • ‎français • ‎Bahasa Indonesia • ‎italiano • ‎Nederlands • ‎português • ‎português do Brasil • ‎русский • ‎中文(台灣)‎

More details can be found on the Joomla! Downloads Portal.

Joomla! 
3.x

Requisitos para Software Soportado

Requisitos para Joomla 3.x Joomla 3.x

Software Recomendado Mínimo Más información
PHP (Magic Quotes GPC, MB String Overload = off / Zlib Compression Support, XML Support, INI Parser Support, JSON Support, Mcrypt Support, MB Language = Default) 5.6 + o 7 +[1] 5.3.10 + www.php.net
Motores de base de datos soportados:
MySQL[2] (Se requiere soporte InnoDB) 5.5.3 + 5.1 + www.mysql.com
SQL Server 10.50.1600.1 + 10.50.1600.1 + www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 + www.postgresql.org
Servidores web soportados:
Apache(con mod_mysql, mod_xml, y mod_zlib)[3][4] 2.4 + 2.x + www.apache.org
Nginx 1.8 + 1.0 + wiki.nginx.org
Microsoft IIS 7 7 www.iis.net


Referencias

  1. Se requiere PHP 5.3.1 para las versiones 3.0 a 3.2. En 3.3, el mínimo se eleva a PHP 5.3.10.
    Sólo las versiones de Joomla! 3.5 y posteriores son compatibles con PHP 7.
  2. Joomla aún no es compatible con MySQL 6.x.
  3. Para poder usar URLs amigables con los motores de búsqueda, necesitará tener la extensión mod_rewrite de Apache instalada.
  4. Se recomienda la extensión mod_suphp o la extensión mod_fcgid para permitir a Joomla subir y ejecutar archivos usando permisos de archivo seguros.

Optional Requirements for Joomla! 3.x

Algunos requisitos técnicos opcionales no son requeridos para instalar y ejecutar Joomla!, pero son requeridos por algunas dependencias que utilizan APIs internos.