Tehnilised nõuded

From Joomla! Documentation

This page is a translated version of the page Technical requirements and the translation is 100% complete.

Other languages:
العربية • ‎Deutsch • ‎English • ‎español • ‎eesti • ‎فارسی • ‎français • ‎Bahasa Indonesia • ‎italiano • ‎Nederlands • ‎português • ‎português do Brasil • ‎русский • ‎中文(台灣)‎

Lisainfot leiad Joomla! allalaadimiste portaalist.

Joomla! 
3.x

Nõuded toetatud tarkvarale

Nõuded Joomla versioonile 3.x Joomla 3.x

Tarkvara Soovitatud Minimaalne Lisainfo
PHP (Magic Quotes GPC, MB String Overload = off / Zlib Compression Support, XML Support, INI Parser Support, JSON Support, Mcrypt Support, MB Language = Default) 5.6 + või 7 +[1] 5.3.10 + www.php.net
Toetatud andmebaasid:
MySQL[2] (InnoDB andmebaasi tugi on nõutud) 5.5.3 + 5.1 + www.mysql.com
SQL Server 10.50.1600.1 + 10.50.1600.1 + www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 + www.postgresql.org
Toetatud veebiserverid:
Apache (moodulitega mod_mysql, mod_xml ja mod_zlib)[3][4] 2.4 + 2.x + www.apache.org
Nginx 1.8 + 1.0 + wiki.nginx.org
Microsoft IIS 7 7 www.iis.net


Viited

  1. PHP 5.3.1 on nõutud versioonidele 3.0 kuni 3.2. Alates versioonist 3.3 on minimaalne PHP versioon on 5.3.10.
    Ainult Joomla! versioonid 3.5 ja uuemad ühilduvad PHP 7-ga.
  2. Joomla ei ühildu veel MySQL versiooniga 6.x.
  3. Otsingumootorisõbralike URL-ide kasutamiseks peab su Apache veebiserveris olema paigaldatud lisaprogramm mod_rewrite.
  4. Kui sa soovid kasutada Joomla üleslaadimise funktsiooni ja turvaliste failiõiguste kasutamiseks on soovitatud lisaprogrammid mod_suphp või mod_fcgid.

Soovituslikud nõuded Joomla! 3.x jaoks

Mõned tehnilised nõuded pole kohustuslikud, et Joomlat kasutada, aga on nõutud mõne sellest nõudest sõltuva sisemise API kasutamiseks.