نیازمندهای فنی

This page is a translated version of the page Technical requirements and the translation is 100% complete.

Other languages:
العربية • ‎Deutsch • ‎English • ‎español • ‎eesti • ‎فارسی • ‎français • ‎Bahasa Indonesia • ‎italiano • ‎Nederlands • ‎português • ‎português do Brasil • ‎русский • ‎中文(台灣)‎

More details can be found on the Joomla! Downloads Portal.

Joomla! 
3.x

نیازمندها برای نرم افزارهای پشتیبانی شده

نیازمندی ها برای جوملا 3.x Joomla 3.x

نرم افزار پیش فرض حداقل اظلاعات بیشتر
PHP (Magic Quotes GPC, MB String Overload = off / Zlib Compression Support, XML Support, INI Parser Support, JSON Support, Mcrypt Support, MB Language = Default) 5.6 + یا 7 +[1] 5.3.10 + www.php.net
پایگاه داده‌های پشتیبانی شده:
MySQL[2] (پشتیبان InnoDB موردنیاز است) 5.5.3 + 5.1 + www.mysql.com
SQL Server 10.50.1600.1 + 10.50.1600.1 + www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 + www.postgresql.org
وب سرورهای پشتیبانی شده:
آپاچی (با mod_mysq ،mod_xml وmod_zlib)[3][4] 2.4 + 2.x + www.apache.org
Nginx 1.8 + 1.0 + wiki.nginx.org
Microsoft IIS 7 7 www.iis.net


منابع

  1. PHP 5.3.1 برای نسخه 3.0 لازم است از طرفی در 3.2. در 3.3 حداقل موردنیاز به PHP 5.3.10 افزایش یافته است.
    تنها جوملا! نسخه‌های 3.5 و بعد از آن با PHP 7 سازگاری دارند.
  2. جوملا هنوز با MySQL 6.x سازگار نیست.
  3. بر طبق کاربرد نشانی‌های وب مناسب موتورهای جستجو، شما نیاز دارید که افزونۀ mod_rewrite آپاچی را نصب کرده باشید.
  4. افزونۀ mod_suphp یا افزونۀ mod_fcgid پیش‌فرض هستند برای اینکه جوملا بارگذاری و اجرای پرونده‌ها را با استفاده از مجوز ایمن پرونده فعال کند.

Optional Requirements for Joomla! 3.x

برخی از نیازمندی‌های فنی که برای نصب و اجرای جوملا! لازم نیستند اما برای برخی وابستگی‌های اجراکننده رابط‌‌های کاربری برنامه نویسی (API) داخلی لازم هستند.

Advertisement