Prérequis techniques

This page is a translated version of the page Technical requirements and the translation is 100% complete.

Other languages:
العربية • ‎Deutsch • ‎English • ‎español • ‎eesti • ‎فارسی • ‎français • ‎Bahasa Indonesia • ‎italiano • ‎Nederlands • ‎português • ‎português do Brasil • ‎русский • ‎中文(台灣)‎

Vous trouverez plus de détails sur le Joomla! Downloads Portal.

Joomla! 
3.x

Prérequis techniques pour les logiciels pris en charge

Prérequis pour Joomla! 3.x Joomla 3.x

Logiciel Recommandé Minimum Informations complémentaires
PHP (Magic Quotes GPC, MB String Overload = off / Zlib Compression Support, XML Support, INI Parser Support, JSON Support, Mcrypt Support, MB Language = Default) 5.6 + ou 7 +[1] 5.3.10 + www.php.net
Bases de données supportées:
MySQL[2] (Support InnoDB requis) 5.5.3 + 5.1 + www.mysql.com
SQL Server 10.50.1600.1 + 10.50.1600.1 + www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 + www.postgresql.org
Serveurs Web pris en charge:
Apache (avec mod_mysql, mod_xml, et mod_zlib)[3][4] 2.4 + 2.x + www.apache.org
Nginx 1.8 + 1.0 + wiki.nginx.org
Microsoft IIS 7 7 www.iis.net


Références

  1. PHP 5.3.1 est nécessaire pour les versions de 3.0 à 3.2. A partir de la 3.3, le minimum requis a été porté à PHP 5.3.10.
    Seules les versions Joomla! 3.5 et supérieures sont compatibles avec PHP 7.
  2. Joomla! n'est pas encore compatible avec MySQL 6.x.
  3. Afin d'utiliser la Réécriture des URL en clair, l'extension mod_rewrite d'Apache doit être installée.
  4. L'extension mod_suphp ou mod_fcgid sont recommandées afin d'autoriser Joomla! à télécharger et exécuter des fichiers avec des permissions sécurisées.

Prérequis optionnels pour Joomla! 3.x

Certain prérequis techniques ne sont pas exigés pour installer et exécuter Joomla, mais peuvent être nécessaires pour certaines dépendances exécutant différentes API internes.

Advertisement