Requisitos Técnicos

This page is a translated version of the page Technical requirements and the translation is 77% complete.

Other languages:
العربية • ‎Deutsch • ‎English • ‎español • ‎eesti • ‎فارسی • ‎français • ‎Bahasa Indonesia • ‎italiano • ‎Nederlands • ‎português • ‎português do Brasil • ‎русский • ‎中文(台灣)‎

Mais detalhes podem ser encontrados no Portal de Downloads Joomla!.

Joomla! 
3.x

Requisitos para o Programa Suportado

Requisitos para Joomla 3.x Joomla 3.x

Programa Recomendado Mínimo Mais informações
PHP (Magic Quotes GPC, MB String Overload = off / Zlib Compression Support, XML Support, INI Parser Support, JSON Support, Mcrypt Support, MB Language = Default) 5.6 + or 7 +[1] 5.3.10 + www.php.net
Bancos de Dados Suportados:
MySQL[2] (Suporte ao InnoDB exigido) 5.5.3 + 5.1 + www.mysql.com
SQL Server 10.50.1600.1 + 10.50.1600.1 + www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 + www.postgresql.org
Servidores Web Suportados:
Apache(com mod_mysql, mod_xml e mod_zlib)[3][4] 2.4 + 2.x + www.apache.org
Nginx 1.8 + 1.0 + wiki.nginx.org
Microsoft IIS 7 7 www.iis.net


References

  1. PHP 5.3.1 é exigido para versões da 3.0 até 3.2. Na 3.3, o mínimo é o PHP 5.3.10.
    Somente as versões Joomla! 3.5 e posteriores são compatíveis com PHP 7.
  2. Joomla ainda não é compatível com MySQL 6.x.
  3. Para usar URLs Amigáveis, será necessário ter instalada a extensão Apache mod_rewrite.
  4. Recomenda-se as extensões mod_suphp ou mod_fcgid para permitri que Joomla envie e execute arquivos com permissões de segurança.

Optional Requirements for Joomla! 3.x

Some optional technical requirements aren't required to install and run Joomla! but are required for some dependencies running different internal APIs.

Advertisement