Technical requirements/pt-pt

From Joomla! Documentation

< Technical requirements

Podem ser encontrados mais detalhes em Joomla.org.

Joomla! 
3.x

Requisitos para o Software Suportado

Requisitos para o Joomla 3.x Joomla 3.x

Software Recomendado Mínimo Mais informação
PHP (Magic Quotes GPC off) 5.6 + or 7 +[1] 5.3.10 + www.php.net
Base de dados suportadas:
MySQL[2] (É necessário o suporte de InnoDB) 5.5.3 + 5.1 + www.mysql.com
SQL Server 10.50.1600.1 + 10.50.1600.1 + www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 + www.postgresql.org
Servidores da Web suportados:
Apache(with mod_mysql, mod_xml, and mod_zlib)[3][4] 2.4 + 2.x + www.apache.org
Nginx 1.8 + 1.0 + wiki.nginx.org
Microsoft IIS 7 7 www.iis.net


References

  1. PHP 5.3.1 é necessário para as versões 3.0 através de 3.2. Na 3.3, o mínimo é elevado para PHP 5.3.10.
    Apenas as versões 3.5 e superior do Joomla! são compatíveis com PHP 7.
  2. O Joomla ainda não é compatível com MySQL 6.x.
  3. Para poder utilizar URLs Amigáveis do Mecanismo de Procura, irá precisar de ter instalada extensão do Apache mod_rewrite.
  4. A extensão mod_suphp ou a extensão mod_fcgid é recomendada para ativar o Joomla para enviar e executar os ficheiros, utilizando as permissões de ficheiro seguro.