Wat is een kwetsbare extensie?

From Joomla! Documentation

This page is a translated version of the page What is a vulnerable extension? and the translation is 100% complete.

Other languages:
Deutsch • ‎English • ‎Nederlands • ‎中文(台灣)‎

Een kwetsbare extensie is een extensie die een beveiligings kwetsbaarheid heeft (of daaraan bijdraagt).

Kwetsbare extensies zijn niet niet per se slecht gecodeerd. Naarmate het web evolueert, veranderen technische vereisten en algemeen aanvaarde coderingspraktijken. Actieve projecten brengen nieuwe versies van hun extensies uit als de vereisten veranderen. Om deze reden is het belangrijk om:

  1. Ken de versie nummers van alle geïnstalleerde extensies
  2. Gebruik alleen de laatste stabiele versie van alle extensies.
  3. Verwijder alle bestanden volledig van instabiele of ongebruikte extensies
  4. Controleer de Vulnerable Extension List geregeld en verwijder of update iedere extensie versie die kwetsbaar wordt bevonden.

Een RSS feed is ook beschikbaar http://feeds.joomla.org/JoomlaSecurityVulnerableExtensions