Che versione di Joomla! dovrei usare?

This page is a translated version of the page What version of Joomla! should you use? and the translation is 100% complete.

Other languages:
العربية • ‎български • ‎Deutsch • ‎English • ‎español • ‎eesti • ‎français • ‎Bahasa Indonesia • ‎italiano • ‎Nederlands • ‎português • ‎português do Brasil • ‎русский

Prima di tutto, è necessario controllare quale versione di Joomla! è in esecuzione sul tuo sito web.

Controllare l'ultima versione del CMS Joomla!. Se non si usa l'ultima versione, leggere le note di rilascio per verificare se è necessario aggiornare. Se una nuova versione è stata fatta per questioni di sicurezza, si consiglia vivamente di eseguire l'aggiornamento il più presto possibile. Si può vedere la storia di rilascio di ogni serie nella tabella sottostante. Fare clic sul collegamento cronologia delle versioni nella colonna note per trovare i dettagli sulla data esatta di rilascio, note di rilascio e il pacchetto e MD5s.

  • Generalmente, si dovrebbe usare l'ultima versione di Joomla! per un nuovo sito, a meno che non ci siano motivi particolari per non farlo.
  • Assicurati di sottoscrivere al feed Avvisi di sicurezza Joomla! . Questo feed RSS è usato per fare gli annunci, tra cui la disponibilità di nuove versioni, che potrebbero influenzare la sicurezza del tuo sito. Hai la possibilità di sottoscriverti a questo feed via RSS o via e-mail.
  • Se utilizzi una versione precedente alla versione corrente (ad esempio, se stai eseguendo 3.1.6 e la versione corrente è 3.4.1), si consiglia di aggiornare alla versione corrente. Ogni release minore corregge una serie di bug e/o problemi di sicurezza. E' sempre buona norma eseguire l'aggiornamento all'ultima versione di manutenzione come un primo passo nella risoluzione di un problema e risolvere gli eventuali problemi di sicurezza recentemente scoperti.

Versioni del CMS Joomla!

Versione del CMS Disponibile Supporto Fine della Vita Tipo Di Aggiornamento Note Ultima Versione
Bug Sicurezza
1.0
X-mark.png
X-mark.png
X-mark.png
22 Luglio 2009 Migrazione a 1.5 Pianificare la Migrazione a 1.5 ora EOL a 1.0.15
1.5
X-mark.png
X-mark.png
X-mark.png
Settembre 2012 Migrazione a 2.5 Pianificare la Migrazione a 2.5 ora
Joomla 1.5 version history
"'EOL"' a 1.5.26
1.6
X-mark.png
X-mark.png
X-mark.png
Agosto 2011 Un-click per 2.5 Aggiornamento a 2.5 ora
Joomla 1.6 version history
1.6.6
1.7
X-mark.png
X-mark.png
X-mark.png
Febbraio 2012 Un-click per 2.5 Aggiornamento a 2.5 ora
Joomla 1.7 version history
1.7.5
2.5
X-mark.png
X-mark.png
X-mark.png
31 Dicembre 2014 Un-click per 3.x Aggiornamento a 3.8.1 ora
Joomla 2.5 version history
2.5.28
3.0
X-mark.png
X-mark.png
X-mark.png
Maggio 2013 Un-click per 3.1 Si consiglia di utilizzare l'aggiornamento un click
Joomla 3.0 version history
3.0.4
3.1
X-mark.png
X-mark.png
X-mark.png
Dicembre 2013 Un-click per 3.2 Si consiglia di utilizzare l'aggiornamento un click
Joomla 3.1 version history
3.1.6
3.2
X-mark.png
X-mark.png
X-mark.png
Ottobre 2014 [1] Un-click per 3.3 Si consiglia di aggiornare la versione di PHP del server web a 5.3.10 o successiva e di passare a Joomla! 3.3
Joomla 3.2 version history
3.2.7
3.3
X-mark.png
X-mark.png
X-mark.png
al rilascio della versione 3.4 One-click Si consiglia di utilizzare l'aggiornamento un-click
Joomla 3.3 version history
3.3.6
3.4
X-mark.png
X-mark.png
X-mark.png
al rilascio della versione 3.5 One-click Consigliato per tutte le nuove installazioni
Joomla 3.4 version history
3.4.8
3.5
X-mark.png
X-mark.png
X-mark.png
al rilascio della versione 3.6 One-click Consigliato per tutte le nuove installazioni
Joomla 3.5 version history
3.5.1
3.6
X-mark.png
X-mark.png
X-mark.png
al rilascio della versione 3.7 One-click Consigliato per tutte le nuove installazioni
Joomla 3.6 version history
3.6.5
3.7
X-mark.png
X-mark.png
X-mark.png
3.7 release One-click Recommended for all new installs
Joomla! 3.7 version history
3.7.5
3.8
Checkmark.png
Checkmark.png
Checkmark.png
3.8 release One-click Recommended for all new installs
Joomla! 3.8 version history
3.8.1
3.9[2] to define[2][3] - - 2 years after the release of 3.9.0, marks end of support for 3.x One-click
4.0

2016

[2][3]
- -


Librerie Esterne Incluse

Una installazione di Joomla! contiene librerie esterne che sono incluse nel CMS di Joomla!. Queste librerie esterne non fanno parte del codice di base. Si prega di leggere la sezione Note in quanto potrebbero contenere più informazioni, come ad esempio un cambio di versione libreria esterna rilasciato con una versione di manutenzione.

Librerie esterne di Joomla

Versione del CMS Versione del CMS Supportata Mootools Mootools More jQuery jQuery UI
(Core, Widget, Mouse, Posizione e Ordinamento)
Bootstrap Simple Pie PHP Mailer PHP UTF-8 IDNA Convert Framework per lo sviluppo rapido di Applicazioni (RAD)
Framework di Akeeba (FOF)
password_compat[4] lessphp password_compat[5]
2.5
X-mark.png
1.4.5[6] 1.4.0.1 N/A[7] N/A[7] N/A[7] 1.2 5.2.1 0.5 N/A[8] N/A[9] N/A[10] N/A[11] N/A[12]
3.0
X-mark.png
1.4.5 1.4.0.1 1.8.1 1.8.23 2.1.0 1.2 5.2.1 0.5 N/A[8] N/A[9] N/A[10] N/A[11] N/A[12]
3.1
X-mark.png
1.4.5 1.4.0.1 1.8.3 1.8.23 2.1.0 1.2[13] 5.2.3 0.5 N/A[8] N/A[9] N/A[10] N/A[11] N/A[12]
3.1.2
X-mark.png
1.4.5 1.4.0.1 1.8.3 1.8.23 2.3.2[14] 1.2[13] 5.2.6 0.5 0.8.0 N/A[9] N/A[10] N/A[11] N/A[12]
3.2
X-mark.png
1.4.5 1.4.0.1 1.10.2[15] 1.9.2 2.3.2[14] 1.2[13] 5.2.6 0.5 0.8.0 2.1 1.0.3 N/A[11] N/A[12]
3.3
X-mark.png
1.4.5 1.4.0.1 1.11.1[15] 1.9.2 2.3.2[14] 1.2[13] 5.2.8 0.5 0.8.0 2.1 1.0.3 N/A[11] N/A[12]
3.4
X-mark.png
1.4.5 1.4.0.1 1.11.3[15] 1.9.2 2.3.2[14] 1.2[13] 5.2.9 0.5 0.8.0 2.4.3 1.0.4 0.3.9 N/A[12]
3.5
X-mark.png
1.4.5 1.4.0.1 1.11.3[15] 1.9.2 2.3.2[14] 1.2[13] 5.2.14 0.5 0.8.0 2.4.3 1.0.4 0.5.0 1.0.10
3.6
X-mark.png
1.4.5 1.4.0.1 1.12.4[15] 1.9.2 2.3.2[14] 1.3.1[13] 5.2.14 0.5 0.8.0 2.4.3 1.0.4 0.5.0 1.4.1
3.7
X-mark.png
1.4.5 1.4.0.1 1.12.4[15] 1.9.2 2.3.2[14] 1.3.1[13] 5.2.14 0.5 0.8.0 2.4.3 1.0.4 0.5.0 1.4.1
3.8
Checkmark.png
1.4.5 1.4.0.1 1.12.4[15] 1.9.2 2.3.2[14] 1.3.1[13] 5.2.14 0.5 0.8.0 2.4.3 1.0.4 0.5.0 1.4.1
3.9
4.0


Spiegazione delle versioni Joomla!

Joomla! 
3.8.1
Versione Stabile

Questa pagina offre una sintesi della strategia di sviluppo attuale pubblicata il 25 Aprile 2014. Tutte le versioni di Joomla rilasciate prima del 25 Aprile 2014 sono state sviluppate secondo il ciclo di rilascio e supporto precedente. Si consiglia di leggere il testo integrale della strategia di sviluppo Joomla per una spiegazione più dettagliata.

Joomla! è stato sviluppato seguendo Semantic Versioning (2.0.0). L'uso di LTS (Long Term Support) e STS (Short Term Support) non è più rilevante o osservato. I termini trovati direttamente sotto verranno utilizzati per chiarezza. È necessario comprendere questi termini e il loro significato.

  • supportata - le ultime versioni minori di una versione principale riceveranno le patch per bug e problemi di sicurezza
  • corrente - è la versione ufficiale più giovane o la più recente major.x.x
  • legacy - qualsiasi versione major.minor.patch che non sia la versione corrente[16]
  • stabile - versione major pronta per l'uso in un ambiente di produzione [17]
  • EOS - un acronimo per "fine del supporto" indica che non verranno rilasciate future patch per i bug o correzioni di sicurezza
  • EOL - un acronimo per 'fine vita', ha lo stesso significato EOS[18]

Ogni versione principale di Joomla! è supportata dal Progetto Joomla!TM per un periodo di tempo limitato, a partire dalla data di rilascio ufficiale. Ogni major release di Joomla sarà sviluppata in maniera attiva per almeno 2 anni. A ciò può seguire uno sviluppo costante fino ad una versione major pianificata sulla tabella di marcia.[19] Una breve sintesi sarebbe:

  • ogni versione principale avrà un minimo di 4 anni di supporto
  • si dovrebbe sempre usare o aggiornarsi all'ultima versione principale del minor.patch
  • ogni minimo aggiornamento della versione rilasciata è compatibile con la precedente versione minore della stessa versione principale[20]

Si prega di utilizzare il grafico Joomla! CMS Roadmap di Sviluppo o Versioni del CMS Joomla! per determinare e prevedere il EOS (fine del supporto) per ogni versione major.minor o per l'intera versione principale.

Spiegazione dei numeri di versione

Gli identificatori di versione per Joomla seguono una convenzione numerica a tre livelli in cui i livelli sono definiti da quanto sono significativi i cambiamenti.

[major].[minor].[patch]

Questi 3 livelli sono definiti come segue:

  1. Un incremento dell'identificativo di versione major indica un'interruzione di retrocompatibilità.
  2. Un incremento dell'identificativo di versione minor indica l'aggiunta di nuove funzionalità o un cambiamento significativo di funzioni esistenti.
  3. Un incremento dell'identificativo di versione patch indica che dei bug sono stati corretti.

Esempi

Stai usando la versione di Joomla 3.3.6. Questo significa che la versione major è 3, la versione minor è 3, la versione di patch è 6. Se una patch viene rilasciata per 3.3.6, verrebbe rilasciata la versione Joomla 3.3.7 . Se una nuova versione minor viene rilasciata, la nuova versione di Joomla diventerebbe 3.4.0 . Questa pagina mostrerà sempre la l'ultima versione stabile rilasciata di Joomla, nell'angolo in alto a destra.


Riferimenti e Note

  1. La correzione di bug cesserà ad aprile 2014, solo aggiornamenti di sicurezza, vedi http://community.joomla.org/blogs/leadership/1798-raising-the-bar-on-security.html.

    Inoltre, per sei mesi dopo il rilascio di Joomla! 3.3, Il Progetto Joomla! rilascerà aggiornamenti di sicurezza per 3.2 e 3.3, in modo che qualsiasi nuova vulnerabilità possa essere prontamente corretta con un aggiornamento un click, senza la necessità di aggiornare immediatamente a Joomla! 3.3, dandovi il tempo di chiedere al vostro fornitore di Hosting per aggiornare la versione di PHP.

  2. 2.0 2.1 2.2 See J3's roadmap for time frames of all future releases of all Joomla! 3 versions.
  3. 3.0 3.1 Please note that dates may be subject to change depending on availability of volunteers and circumstances beyond the PLT's control.
  4. Questa libreria serve a fornire la compatibilità con le funzioni password_* che sono state aggiunte a PHP 5.5. Per ulteriori informazioni vedere password_compat git.
  5. Questa libreria serve a fornire la compatibilità con le funzioni random_bytes e random_int che sono state aggiunte a PHP 7.0. Per ulteriori informazioni vedere random_compat git.
  6. Contiene un livello 1.2 di compatibilità
  7. 7.0 7.1 7.2 Non applicabile, questa libreria non è stata inclusa nella versione 2.5 del CMS Joomla!.
  8. 8.0 8.1 8.2 Non applicabile, questa libreria non è stata inclusa nelle versioni precedenti alla 3.1.2 del CMS Joomla!
  9. 9.0 9.1 9.2 9.3 Non applicabile, questa libreria non è stata inclusa nelle versioni precedenti alla 3.2 del CMS Joomla!. La versione di FOF incluso in Joomla 3.2 è compatibile con Joomla 2.5.
  10. 10.0 10.1 10.2 10.3 Non applicabile,questa libreria non è stata inclusa nelle versioni precedenti alla 3.2 del CMS Joomla!
  11. 11.0 11.1 11.2 11.3 11.4 11.5 Non applicabile, questa libreria non è stata inclusa nelle versioni precedenti alla 3.4 del CMS Joomla!
  12. 12.0 12.1 12.2 12.3 12.4 12.5 12.6 Non applicabile, questa libreria non è stata inclusa nelle versioni precedenti alla 3.5 del CMS Joomla!
  13. 13.0 13.1 13.2 13.3 13.4 13.5 13.6 13.7 13.8 Questa libreria è stata deprecata per JFeedFactory nel CMS Joomla! versione 3.1.0
  14. 14.0 14.1 14.2 14.3 14.4 14.5 14.6 14.7 Contiene alcune compatibilità con la 2.1
  15. 15.0 15.1 15.2 15.3 15.4 15.5 15.6 Include il plugin jQuery Migrate versione 1.2.1 per la compatibilità all'indietro
  16. Nota, il legacy è un termine usato per designare unicamente lo stato di una versione rispetto alla versione corrente. Gli utenti e gli sviluppatori dovrebbero prestare particolare attenzione alla data di EOS per determinare se è opportuno utilizzare la versione.
  17. Le versioni contrassegnate con alfa, beta o rc (release candidate) dovrebbero essere utilizzate solo a scopo di test.
  18. EOS può essere usato in modo intercambiabile con EOL. Il termine indica la "fine del supporto" e niente di più. 'EOL' non significa che il software cesserà di funzionare.
  19. La spiegazione completa delle versioni supportate può essere trovato sotto la voce 4.3 Release supportate sul documento sulla Strategia di Sviluppo.
  20. Un'estensione o un template installato sulla versione major.0.x funziona anche sulla versione major.7.x. L'estensione o il template sono creati da sviluppatori di terze parti e i loro aggiornamenti sono a carico di ogni sviluppatore. L'installazione degli aggiornamenti delle estensioni e dei template sono a carico dell'utente.
Advertisement