Welke versie van Joomla! moet u gebruiken?

This page is a translated version of the page What version of Joomla! should you use? and the translation is 100% complete.

Other languages:
العربية • ‎български • ‎Deutsch • ‎English • ‎español • ‎eesti • ‎français • ‎Bahasa Indonesia • ‎italiano • ‎Nederlands • ‎português • ‎português do Brasil • ‎русский

Allereerst moet u controleren welke Versie van Joomla! actief is op uw website.

Controleer op de nieuwste Joomla! CMS versie. Lees, als u de nieuwste release niet gebruikt, de release notes om te kijken of u moet upgraden. Als een release wordt gemaakt om een beveiligingsproblemen op te lossen, wordt sterk aangeraden zo snel mogelijk te upgraden. U kunt de geschiedenis van releases in onderstaande tabel terugvinden. Klik op de versie historie link in de opmerkingen kolom om details te vinden van de exacte release datum, release notes en MD5's van de pakketten.

  • Normaliter moet u de nieuwste versie van Joomla! gebruiken voor een nieuwe site tenzij u een specifieke reden heeft om dat niet te doen.
  • De nieuwste versie kan gedownload worden vanaf de Joomla! downloads website.
  • Zorg dat u zich abonneert op de Joomla! beveiligingsaankondigingen feed. Deze RSS feed wordt gebruikt om aankondigingen, met inbegrip van de beschikbaarheid van nieuwe releases, te doen die de veiligheid van uw site beïnvloeden. U kunt zich abonneren op de feed via RSS of e-mail.
  • Als u een eerdere versie van de huidige versie (bijvoorbeeld, u heeft 3.1.6 en de huidige versie is 3.4.5), moet u upgraden naar de huidige versie. Elke kleine versie lost een aantal bugs en/of veiligheidsproblemen. Het is altijd goed om te upgraden naar de nieuwste onderhouds-versie als een eerste stap in het oplossen van een probleem en de vaststelling van een nieuw ontdekte beveiligingsproblemen.

Joomla! CMS versies

CMS versie Beschikbaar Ondersteuning Beëindigd (eol) Upgrade type Opmerkingen Nieuwste release
Bugs Veiligheid
1.0
X-mark.png
X-mark.png
X-mark.png
22 juli 2009 Migratie naar 1.5 Plan nu om naar 1.5 te migreren EOL bij 1.0.15
1.5
X-mark.png
X-mark.png
X-mark.png
Sept 2012 Migratie naar 2.5 Plan nu om naar 2.5 te migreren
Joomla 1.5 versie historie
EOL bij 1.5.26
1.6
X-mark.png
X-mark.png
X-mark.png
Aug 2011 Met één klik naar 2.5 Upgrade nu naar 2.5
Joomla 1.6 versie historie
1.6.6
1.7
X-mark.png
X-mark.png
X-mark.png
Feb 2012 Met één klik naar 2.5 Upgrade nu naar 2.5
Joomla 1.7 versie historie
1.7.5
2.5
X-mark.png
X-mark.png
X-mark.png
31 dec 2014 Met één klik naar 3.x Upgrade naar 3.8.1 nu
Joomla 2.5 versie historie
2.5.28
3.0
X-mark.png
X-mark.png
X-mark.png
Mei 2013 Met één klik naar 3.1 Gebruik de één klik upgrade
Joomla 3.0 versie historie
3.0.4
3.1
X-mark.png
X-mark.png
X-mark.png
Dec 2013 Met één klik naar 3.2 Gebruik de één klik upgrade
Joomla 3.1 versie historie
3.1.6
3.2
X-mark.png
X-mark.png
X-mark.png
Okt 2014[1] Met één klik naar 3.3 U moet de PHP versie op de server upgraden naar 5.3.10 of hoger en upgraden naar 3.3
Joomla 3.2 versie historie
3.2.7
3.3
X-mark.png
X-mark.png
X-mark.png
3.4 release Met één klik Gebruik de één-klik upgrade
Joomla 3.3 versie historie
3.3.6
3.4
X-mark.png
X-mark.png
X-mark.png
3.5 release Met één klik Aanbevolen voor alle nieuwe installaties
Joomla 3.4 versie historie
3.4.8
3.5
X-mark.png
X-mark.png
X-mark.png
3.6 release Met één klik Aanbevolen voor alle nieuwe installaties
Joomla 3.5 versie historie
3.5.1
3.6
X-mark.png
X-mark.png
X-mark.png
3.7 release Met één klik Aanbevolen voor alle nieuwe installaties
Joomla 3.6 versie historie
3.6.5
3.7
X-mark.png
X-mark.png
X-mark.png
3.7 release One-click Recommended for all new installs
Joomla! 3.7 version history
3.7.5
3.8
Checkmark.png
Checkmark.png
Checkmark.png
3.8 release One-click Recommended for all new installs
Joomla! 3.8 version history
3.8.1
3.9[2] te bepalen[2][3] - - 2 jaar na de release van 3.9.0 stopt de ondersteuning voor 3.x Met één klik
4.0 te definiëren[2][3] - -


Ingevoegde externe libraries

Een Joomla! installatie bevat externe libraries die zijn ingevoegd binnen Joomla! CMS versie releases. Deze externe libraries zijn geen onderdeel van de core code. Lees ook de Opmerkingen sectie, deze kan extra informatie bevatten zoals een verandering van versie van een externe librarie samen met een onderhoudsrelease.

Externe libraries per Joomla release

CMS versie CMS versie ondersteuning Mootools Mootools meer jQuery jQuery UI
(Core, Widget, Mouse, Position, and Sortable)
Bootstrap Simple Pie PHP Mailer PHP UTF-8 IDNA Convert Rapid Application Development (RAD) Framework
Akeeba's Framework on Framework(FOF)
password_compat[4] lessphp random_compat[5]
2.5
X-mark.png
1.4.5[6] 1.4.0.1 N/B[7] N/B[7] N/B[7] 1.2 5.2.1 0.5 N/A[8] N/B[9] N/B[10] N/A[11] N/A[12]
3.0
X-mark.png
1.4.5 1.4.0.1 1.8.1 1.8.23 2.1.0 1.2 5.2.1 0.5 N/A[8] N/B[9] N/B[10] N/A[11] N/A[13]
3.1
X-mark.png
1.4.5 1.4.0.1 1.8.3 1.8.23 2.1.0 1.2[14] 5.2.3 0.5 N/B[8] N/B[9] N/B[10] N/A[11] N/A[13]
3.1.2
X-mark.png
1.4.5 1.4.0.1 1.8.3 1.8.23 2.3.2[15] 1.2[14] 5.2.6 0.5 0.8.0 N/A[9] N/A[10] N/A[11] N/A[13]
3.2
X-mark.png
1.4.5 1.4.0.1 1.10.2[16] 1.9.2 2.3.2[15] 1.2[14] 5.2.6 0.5 0.8.0 2.1 1.0.3 N/A[11] N/A[13]
3.3
X-mark.png
1.4.5 1.4.0.1 1.11.1[16] 1.9.2 2.3.2[15] 1.2[14] 5.2.8 0.5 0.8.0 2.1 1.0.3 N/A[11] N/A[13]
3.4
X-mark.png
1.4.5 1.4.0.1 1.11.3[16] 1.9.2 2.3.2[15] 1.2[14] 5.2.9 0.5 0.8.0 2.4.3 1.0.4 0.3.9 N/A[13]
3.5
X-mark.png
1.4.5 1.4.0.1 1.11.3[16] 1.9.2 2.3.2[15] 1.2[14] 5.2.14 0.5 0.8.0 2.4.3 1.0.4 0.5.0 1.0.10
3.6
X-mark.png
1.4.5 1.4.0.1 1.12.4[16] 1.9.2 2.3.2[15] 1.3.1[14] 5.2.14 0.5 0.8.0 2.4.3 1.0.4 0.5.0 1.4.1
3.7
X-mark.png
1.4.5 1.4.0.1 1.12.4[16] 1.9.2 2.3.2[15] 1.3.1[14] 5.2.14 0.5 0.8.0 2.4.3 1.0.4 0.5.0 1.4.1
3.8
Checkmark.png
1.4.5 1.4.0.1 1.12.4[16] 1.9.2 2.3.2[15] 1.3.1[14] 5.2.14 0.5 0.8.0 2.4.3 1.0.4 0.5.0 1.4.1
3.9
4.0


Joomla! versies verklaard

Joomla! 
3.8.1
Stabiele versie

This page provides a summary of the current development strategy published on 25 April 2014. All Joomla versions released before 25 April 2014 have been developed according to previous release and support cycle. You should read the full text of the Joomla development strategy for a more detailed explanation.

Joomla! wordt ontwikkeld volgens Semantic Versioning (2.0.0). Het gebruik van LTS (Langetermijn ondersteuning) en STS (kortetermijn ondersteuning) is niet meer van toepassing. Voor de duidelijkheid worden onderstaande termen gebruikt, waarvan u de betekenis zou moeten begrijpen.

  • supported - latest minor version(s) of a major version will receive patches which will include bug and security fixes
  • current - the youngest or 'latest' major.x.x officially released version
  • legacy - any major.minor.patch version(s) which are not the current version[17]
  • stable - major version ready for use in a production environment implied with current and legacy[18]
  • EOS - an acronym for 'end of support' which indicates no further patches will be released for bugs or security fixes
  • EOL - an acronym for 'end of life' which indicates the same meaning as EOS[19]

Iedere hoofdversie van Joomla! wordt ondersteund door het Joomla! ProjectTM voor een bepaalde tijd gerekend vanaf de begindatum waarop de hoofdversie is vrijgegeven. Joomla zal iedere hoofdversie minimaal 2 jaar actief ontwikkelen. Deze kan vervolgd worden door verdere ontwikkeling van een hoofdversie volgens het schema van het stappenplan van de hoofdversie.[20] Een korte samenvatting:

  • iedere hoofdversie wordt minimaal 4 jaar ondersteund
  • u moet altijd de nieuwste sub.onderhoudsversie gebruiken van een hoofdversie of daarnaar updaten
  • iedere update van een subversie is terugwaarts compatibel met de vorige subversie van dezelfde hoofdversie[21]

Raadpleeg het Joomla! CMS ontwikkeling stappenplan of de Joomla! CMS versies grafiek om de geschatte EOS (einde ondersteuning) te bepalen van iedere hoofd.sub versie of de volledige hoofdversie.

Uitleg versienummering

Joomla versies worden aangeduid door middel van een numerieke structuur die bestaat uit drie niveaus, waarbij per niveau de mate van aanpassing aan de software bepaald wordt.

[major].[minor].[patch]

Deze 3 niveaus zijn als volgt gedefineerd:

  1. Een ophoging van de major (hoofdversie) aanduiding geeft aan dat er met de terugwaartse compatibiliteit gebroken wordt.
  2. Een ophoging van de minor (subversie) aanduiding geeft nieuwe toevoegingen aan of een aanzienlijke verandering aan bestaande functies.
  3. Een ophoging van de patch (onderhoudsversie) aanduiding geeft aan dat er bugs zijn opgelost.

Voorbeelden

U gebruikt Joomla versie 3.3.6. Dat betekent dat uw hoofdversie 3 is, uw subversie 3 is en uw onderhoudsversie 6 is. Wanneer er een nieuwe onderhoudsupdate vrijgegeven wordt voor 3.3.6, wordt het versienummer opgehoogd naar 3.3.7. Wanneer er een nieuwe subversie uitgebracht wordt voor de hoofdversie 3 wordt uw nieuwe Joomla versie 3.4.0. Bovenaan in de rechterhoek van deze pagina wordt altijd de huidige stabiele ondersteunde versie van Joomla, inclusief de subversie en de onderhoudsversie, weergegeven.


Referenties en opmerkingen

  1. Bug fixes stoppen in april 2014, alleen veiligheidsaanpassingen, zie http://community.joomla.org/blogs/leadership/1798-raising-the-bar-on-security.html.

    "Ook voor de zes maanden nadat Joomla! 3.3 is vrijgegeven, zal het Joomla! project veiligheidsupdates vrijgeven voor zowel 3.2 ALS 3.3 zodat iedere nieuwe kwetsbaarheid opgelost kan worden met één klik zonder de noodzaak direct naar Joomla! 3.3 te updaten, zodat uw hoster tijd krijgt om de PHP versie te updaten."

  2. 2.0 2.1 2.2 Zie J3's stappenplan voor tijdpaden van alle toekomstige releases van alle Joomla! 3 versies.
  3. 3.0 3.1 Let op: de data kunnen aan wijzigingen onderhevig zijn afhankelijk van de beschikbaarheid van vrijwilligers en omstandigheden buiten de PLT.
  4. Deze library is bestemd om voorwaartse compatibiliteit te verstrekken met de password_* functies die toegevoegd zijn aan PHP 5.5. Zie password_compat git voor verdere informatie.
  5. Deze bibliotheek is bedoeld om voorwaartse compatibiliteit te verzorgen met de random_bytes en random_int functies die aan PHP 7.0 zijn toegevoegd. Zie random_compat git voor meer informatie.
  6. Bevat een 1.2 compatibiliteitslaag
  7. 7.0 7.1 7.2 Niet van toepassing, deze library was niet ingevoegd in Joomla! CMS versie 2.5.
  8. 8.0 8.1 8.2 Niet van toepassing, deze bibliotheek was niet toegevoegd met de Joomla! CMS voor versie 3.1.2.
  9. 9.0 9.1 9.2 9.3 Niet van toepassing, deze library was niet ingevoegd in de Joomla! CMS versie ouder dan 3.2. Overigens is de versie van FOF die in Joomla 3.2 is ingevoegd compatibel met Joomla 2.5.
  10. 10.0 10.1 10.2 10.3 Niet van toepassing, deze library was niet ingevoegd in de Joomla! CMS versie ouder dan 3.2.
  11. 11.0 11.1 11.2 11.3 11.4 11.5 Niet van toepassing, deze bibliotheek was niet toegevoegd aan de Joomla! CMS voor versie 3.4
  12. Niet van toepassing, deze bibliotheek was niet toegevoegd aan de Joomla! CMS voor versie 3.5
  13. 13.0 13.1 13.2 13.3 13.4 13.5 Cite error: Invalid <ref> tag; no text was provided for refs named naRandom
  14. 14.0 14.1 14.2 14.3 14.4 14.5 14.6 14.7 14.8 Deze library is vervangen door JFeedFactory in Joomla! CMS versie 3.1.0
  15. 15.0 15.1 15.2 15.3 15.4 15.5 15.6 15.7 Bevat enkele 2.1 terugwaartse compatibiliteit standaarden
  16. 16.0 16.1 16.2 16.3 16.4 16.5 16.6 Bevat jQuery Migrate plugin 1.2.1 voor terugwaartse compatibiliteit
  17. Note, legacy is a term used to only designate the status of a version in relation to the current version. Users and developers should pay close attention to the EOS date(s) to determine the viability of legacy version use or continued use.
  18. Version(s) marked with alpha, beta or rc (release candidate) should be used for testing only.
  19. EOS may be used interchangeably with EOL. Either term indicates the 'end of support' and nothing more. Do not confuse 'EOL' to mean the software will cease to work.
  20. De volledige uitleg van ondersteunde vrijgaven vindt u onder de kop, 4.3 Supported releases in het Joomla ontwikkelingsstrategie document.
  21. Een extensie of template die geïnstalleerd is op hoofd.0.xversie zal werken op hoofd.7.xversie. Extensie of template zijn gemaakt door een 3e partij ontwikkelaar die verantwoordelijk is voor het publiceren van de updates daarvan. Gebruikers zijn verantwoordelijk voor de installatie van extensie of template updates.
Advertisement