Будут ли мои [совместимые с] Joomla! 2.5 расширения работать с Joomla! 3.x?

From Joomla! Documentation

This page is a translated version of the page Will my Joomla! 2.5 extensions work with Joomla! 3.x? and the translation is 100% complete.

Other languages:
български • ‎Deutsch • ‎English • ‎español • ‎français • ‎Bahasa Indonesia • ‎Nederlands • ‎português • ‎русский
Joomla! 
3.x
серия

Собственные расширения Joomla! 2.5 должны работать с Joomla! 3.0 с очень небольшими изменениями, если они вообще будут нужны. Больше всего будет необходимо поработать над компонентами и шаблонами, в то время как модули и плагины должны работать без проблем (при условии, что они не используют устаревшием методы [программирования]). Расширения, один и тот же пакет которых поддерживает как Joomla! 2.5, так и Joomla! 1.5, скорее всего сразу работать не будут и будут нуждаться в обновлении своими разработчиками для совместимости с Joomla! 3.

Вкратце, это зависит от данного расширения. Проект Joomla! сделал этот процесс для некоторых расширения относительно легким, однако для некоторых других расширении будет необходимо потрудиться. Для полной ясности, свяжитесь с разработчиком нужного расширения и дайте ему знать о том, что Вы желаете использовать его расширение с Joomla! 3. Также проконсультируйтесь с его документацией.