Joomla ADFS Extensions

From Joomla! Documentation

Revision as of 22:54, 10 February 2011 by Schakra (talk | contribs) (New page: This document describes how to enable Active Directory Authentication for Joomla!<br /><br /> '''Prerequisites''' <ol> <li>Joomla 1.5 or 1.6</li> <li>PHP 5.2 with mhash & mcrypt and Op...)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

This document describes how to enable Active Directory Authentication for Joomla!

Prerequisites

  1. Joomla 1.5 or 1.6
  2. PHP 5.2 with mhash & mcrypt and OpenSSL enabled.
  3. Joomla site configure with https. So that ADFS can communicate through SS.L
  4. Active directory federation service with Relying party trust set up to your domain/site.

Active Directory Relying Party Configuration Active directory Relying party configuration is described in a separate document. Please refer to ADFS - Relying Party Trust Configuration