J2.5

Potential backward compatibility issues in Joomla 2.5 and Joomla Platform 11.4

From Joomla! Documentation

Revision as of 18:50, 2 December 2011 by Realityking (talk | contribs) (→‎JFTP)

The "J2.5" namespace is a namespace scheduled to be archived. This page contains information for a Joomla! version which is no longer supported. It exists only as a historical reference, it will not be improved and its content may be incomplete and/or contain broken links.

This documents track potential backward compatibility issues for Joomla 1.7 and Joomla Platform 11.1 which will be included in Joomla 1.7. Listed are issues which potentially breaks extensions and newly deprecated APIs. Please help making this document complete.

The base of this comparison is Joomla 1.7/Platform 11.2.

Backwards compatibility issues were also tracked for Joomla 1.7: [Potential backward compatibility issues in Joomla 1.7 and Joomla Platform 11.1]

Platform[edit]

JFTP[edit]

  • All class members except JFTP::$instances have become private

JError[edit]

  • JError::$_error has become protected

JRequest[edit]

  • JRequest::_cleanArray has been removed

JAtchive[edit]

  • The following class member have become private:
    • JArchiveGzip:: $_flags
    • JArchiveGzip:: $_data
    • JArchiveTar:: $_types
    • JArchiveTar:: $_flags
    • JArchiveTar:: $_data
    • JArchiveTar:: $_metadata
    • JArchiveZip:: $_methods
    • JArchiveZip:: $_ctrlDirHeader
    • JArchiveZip:: $_ctrlDirEnd
    • JArchiveZip:: $_fileHeader
    • JArchiveZip:: $_data

CMS[edit]