Actions

Difference between revisions of "Should I launch a Joomla! 2.5 site or a 3.x site?"

From Joomla! Documentation

m (includeonly a reference to FAQs below when article is transcluded)
 
(13 intermediate revisions by 5 users not shown)
Line 1: Line 1:
Launch a 2.5 site if you want the most stable that Joomla has to offer and/or possibly if you plan on using many extensions. Launch a 3.0 site if all the extensions that you plan to use are Joomla 3.0 compatible. Only some template providers or the extension vendors will be ready for Joomla 3.0 at launching, however most will not be ready until days, weeks or months after.  <includeonly>(See the “How do I find Joomla 3.0 compatible extensions?” FAQ below for more information)</includeonly>
+
<noinclude><languages /></noinclude>
<noinclude>[[Category:Version 3.0 FAQ]][[Category:Version 2.5 FAQ]]</noinclude>
+
 
 +
<translate>
 +
<!--T:1-->
 +
Joomla! 2.5 reached EOS (end of support) the 31 Dec 2014. That means that since that day it will recieve no further attention or support from the Joomla! Project. No more maintenance or security releases. So you should not start a new site with Joomla! 2.5, but always Joomla! 3.3 or greater.
 +
</translate>
 +
 
 +
<translate>
 +
<!--T:2-->
 +
Sites that are currently on Joomla! 2.5 are encouraged to start planning now for a migration to 3.3 or greater now. We’ve provided a one-click upgrade from Joomla! 2.5 to any Joomla! 3 version and you just have to make sure that all your extensions and template are compatible with Joomla! 3.x before upgrading. See [[S:MyLanguage/Planning_for_Mini-Migration_-_Joomla_2.5_to_3.x|Planning for Mini-Migration - Joomla 2.5 to 3.x]]
 +
<includeonly>(See the “How do I find Joomla 3.x compatible extensions?” FAQ below for more information)</includeonly>
 +
</translate>
 +
 
 +
<translate><!--T:3-->
 +
See also: [[S:MyLanguage/Why Migrate|Why Migrate]] and all the related pages.</translate>
 +
 
 +
<noinclude>
 +
<translate>
 +
<!--T:4-->
 +
[[Category:Version 2.5 FAQ]]
 +
[[Category:Version 3.x FAQ]]
 +
[[Category:Version 3.0 FAQ]]
 +
[[Category:Version 3.1 FAQ]]
 +
[[Category:Version 3.2 FAQ]]
 +
[[Category:Version 3.3 FAQ]]
 +
</translate>
 +
</noinclude>

Latest revision as of 19:30, 4 March 2015

Other languages:
English • ‎español • ‎français • ‎Nederlands • ‎português • ‎русский

Joomla! 2.5 reached EOS (end of support) the 31 Dec 2014. That means that since that day it will recieve no further attention or support from the Joomla! Project. No more maintenance or security releases. So you should not start a new site with Joomla! 2.5, but always Joomla! 3.3 or greater.

Sites that are currently on Joomla! 2.5 are encouraged to start planning now for a migration to 3.3 or greater now. We’ve provided a one-click upgrade from Joomla! 2.5 to any Joomla! 3 version and you just have to make sure that all your extensions and template are compatible with Joomla! 3.x before upgrading. See Planning for Mini-Migration - Joomla 2.5 to 3.x


See also: Why Migrate and all the related pages.