Actions

Difference between revisions of "Should I update from Joomla! 2.5 to 3.x?"

From Joomla! Documentation

m (Missing word)
 
(12 intermediate revisions by 5 users not shown)
Line 1: Line 1:
In most cases, probably not. Joomla 2.5 will continue be supported until December 31st of 2014 and you can update directly to Joomla 3 once it’s tried-and-tested thoroughly by other users. You can even wait until Joomla 3.5 which will be released in a year from now and still get a direct upgrade. The only reason you should update is if you need Joomla 3’s features or want to be on the leading edge.
+
<noinclude><languages /></noinclude>
<noinclude>[[Category:Version 3.0 FAQ]][[Category:Version 2.5 FAQ]]</noinclude>
+
 
 +
<translate>
 +
<!--T:1-->
 +
In most cases, you will need to start planning on an upgrade to Joomla! 3.x ASAP. Joomla! 2.5 has reached '''EOS (end of support)''' as of December 31st of 2014. Joomla 3 is stable and should be the choice for production sites.
 +
</translate>
 +
 
 +
<translate>
 +
<!--T:2-->
 +
You will need to verify your template and components will work with Joomla! 3.x before upgrading. All core components are upgrade ready right now.
 +
</translate>
 +
 
 +
<translate>
 +
<!--T:3-->
 +
Please see [[S:MyLanguage/Why Migrate|Why Migrate]] for more details on migration from 2.5 to 3.x.
 +
</translate>
 +
 
 +
<noinclude>
 +
<translate>
 +
<!--T:4-->
 +
[[Category:Version 2.5 FAQ]]
 +
[[Category:Version 3.x FAQ]]
 +
[[Category:Version 3.0 FAQ]]
 +
[[Category:Version 3.1 FAQ]]
 +
[[Category:Version 3.2 FAQ]]
 +
[[Category:Version 3.3 FAQ]]
 +
[[Category:Update Working Group]]
 +
</translate>
 +
</noinclude>

Latest revision as of 12:52, 3 January 2015

Other languages:
English • ‎español • ‎français

In most cases, you will need to start planning on an upgrade to Joomla! 3.x ASAP. Joomla! 2.5 has reached EOS (end of support) as of December 31st of 2014. Joomla 3 is stable and should be the choice for production sites.

You will need to verify your template and components will work with Joomla! 3.x before upgrading. All core components are upgrade ready right now.

Please see Why Migrate for more details on migration from 2.5 to 3.x.