Actions

Difference between revisions of "Technical requirements"

From Joomla! Documentation

m (need a split)
 
(30 intermediate revisions by 11 users not shown)
Line 1: Line 1:
More details can be found on [http://www.joomla.org/about-joomla/technical-requirements.html Joomla.org].
+
<noinclude><languages /></noinclude>
  
= Joomla 1.6/1.7/2.5 {{JVer|1.6}}{{JVer|1.7}}{{JVer|2.5}} =
+
{{JSplit}}
 +
<translate><!--T:1-->
 +
More details can be found on [http://www.joomla.org/about-joomla/technical-requirements.html Joomla.org].</translate>
  
 +
==<translate><!--T:2-->
 +
Joomla 3.x {{JVer|3.x}}</translate>==
 +
<section begin=Joomla 3.x />
 
{| class="wikitable" border="1"
 
{| class="wikitable" border="1"
!Software
+
!<translate><!--T:3-->
!Recommended
+
Software</translate>
!Minimum
+
!<translate><!--T:4-->
 +
Recommended</translate>
 +
!<translate><!--T:5-->
 +
Minimum</translate>
 
|-
 
|-
|PHP
+
|<translate><!--T:6-->
|5.3+
+
PHP (Magic Quotes GPC off)</translate>
|5.2.4+
+
|5.4 +
 +
|5.3.10 +
 
|-
 
|-
|MySQL
+
| colspan=3 style="background-color:#e1e1e1;" | <translate><!--T:7-->
|5.0.4+
+
Supported Databases</translate>:
|5.0.4+
+
 
|-
 
|-
|Apache<ref name="mod_rewrite">In order to use [[SEF URLs]], you will need to have the Apache mod_rewrite extension installed.</ref>
+
|MySQL<ref name="MySQL6.0"><translate><!--T:8-->
 +
Joomla is not yet compatible with MySQL 6.x.</translate></ref> (<translate><!--T:9-->
 +
InnoDB support required</translate>)
 +
|5.1 +
 +
|5.1 +
 +
|-
 +
|MSSQL
 +
|10.50.1600.1 +
 +
|10.50.1600.1 +
 +
|-
 +
|PostgreSQL
 +
|8.3.18 +
 +
|8.3.18 +
 +
|-
 +
| colspan=3 style="background-color:#e1e1e1;" | <translate><!--T:10-->
 +
Supported Web Servers</translate>:
 +
|-
 +
|<translate><!--T:11-->
 +
Apache(with mod_mysql, mod_xml, and mod_zlib)</translate><ref name="mod_rewrite"><translate><!--T:12-->
 +
In order to use [[Search Engine Friendly URLs]], you will need to have the Apache mod_rewrite extension installed.</translate></ref><ref name="PHPFileHandler"><translate><!--T:13-->
 +
The [http://www.suphp.org mod_suphp] extension or [http://httpd.apache.org/mod_fcgid mod_fcgid] extension is recommended to enable Joomla to upload and execute files using secure file permissions.</translate></ref>
 
|2.x+
 
|2.x+
 
|2.x+
 
|2.x+
 
|-
 
|-
|Microsoft IIS<ref>For Microsoft IIS you need MySQL 5.1 or newer.</ref>
+
|Hiawatha (<translate><!--T:14-->
 +
with [https://www.hiawatha-webserver.org/howto/url_rewrite_rules#joomla UrlToolkit] support</translate>)
 +
|<translate><!--T:15-->
 +
latest</translate>
 +
|8.0
 +
|-
 +
|Nginx
 +
|1.1
 +
|1.0
 +
|-
 +
|Microsoft IIS
 
|7
 
|7
 
|7
 
|7
 
|}
 
|}
 +
<section end=Joomla 3.x />
  
= Joomla 1.5 {{JVer|1.5}} =
+
==Joomla 2.5.x {{JVer|2.5}}==
  
 
{| class="wikitable" border="1"
 
{| class="wikitable" border="1"
!Software
+
!<translate><!--T:16-->
!Recommended
+
Software</translate>
!Minimum
+
!<translate><!--T:17-->
 +
Recommended</translate>
 +
!<translate><!--T:18-->
 +
Minimum</translate>
 
|-
 
|-
|PHP<ref>Do not use PHP 4.3.9, 4.4.2 or 5.0.4. These releases have known bugs that will interfere with installation. Zend Optimizer 2.5.10 for PHP 4.4.x also has serious bugs and you should ask your host to upgrade to a newer version. Joomla! versions 1.5.15 + are compatible with PHP 5.3. Note that the OpenID library is not yet compatible with PHP 5.3.</ref>
+
|PHP
|5.2+
+
|5.4+
|4.3.10
+
|5.2.4+
 
|-
 
|-
|MySQL
+
| colspan=3 style="background-color:#e1e1e1;" | <translate><!--T:19-->
|4.1.x+
+
Supported Databases</translate>:
|3.23
+
 
|-
 
|-
|Apache<ref name="mod_rewrite" />
+
|MySQL<ref name="MySQL6.0" />
 +
|5.0.4+
 +
|5.0.4+
 +
|-
 +
| colspan=3 style="background-color:#e1e1e1;" | <translate><!--T:20-->
 +
Supported Web Servers</translate>:
 +
|-
 +
|<translate><!--T:21-->
 +
Apache (with mod_mysql, mod_xml, and mod_zlib)</translate><ref name="mod_rewrite" /><ref name="PHPFileHandler" />
 +
|2.x+
 
|2.x+
 
|2.x+
|1.3
 
 
|-
 
|-
|Microsoft IIS
+
|Hiawatha (<translate><!--T:22-->
 +
with [https://www.hiawatha-webserver.org/howto/url_rewrite_rules#joomla UrlToolkit] support</translate>)
 +
|<translate><!--T:23-->
 +
latest</translate>
 +
|8.0
 +
|-
 +
|Nginx
 +
|1.1
 +
|1.0
 +
|-
 +
|Microsoft IIS<ref name="MSIIS"><translate><!--T:24-->
 +
For Microsoft IIS you need MySQL 5.1 or newer.</translate></ref>
 +
|7
 
|7
 
|7
|6
 
 
|}
 
|}
  
 +
 +
==References==
 
<references />
 
<references />
<noinclude>
+
<noinclude><translate>
 +
<!--T:25-->
 
[[Category:Joomla! 1.5]]
 
[[Category:Joomla! 1.5]]
 
[[Category:Joomla! 1.6]]
 
[[Category:Joomla! 1.6]]
[[Category:Joomla! 1.7]]</noinclude>
+
[[Category:Joomla! 1.7]]
 +
[[Category:Joomla! 2.5]]
 +
[[Category:Joomla! 3.0]]</translate></noinclude>

Latest revision as of 09:28, 5 February 2015

Other languages:
English • ‎español • ‎français • ‎Nederlands
Split-icon.png
Split Page into Specific Joomla! Versions - J2.5 and J3.1

It has been suggested that this article or section be split into specific version Namespaces. (Discuss). If version split is not obvious, please allow split request to remain for 1 week pending discussions. Proposed since 25 days ago.

More details can be found on Joomla.org.

Joomla 3.x Joomla 3.x

Software Recommended Minimum
PHP (Magic Quotes GPC off) 5.4 + 5.3.10 +
Supported Databases:
MySQL[1] (InnoDB support required) 5.1 + 5.1 +
MSSQL 10.50.1600.1 + 10.50.1600.1 +
PostgreSQL 8.3.18 + 8.3.18 +
Supported Web Servers:
Apache(with mod_mysql, mod_xml, and mod_zlib)[2][3] 2.x+ 2.x+
Hiawatha (with UrlToolkit support) latest 8.0
Nginx 1.1 1.0
Microsoft IIS 7 7


Joomla 2.5.x Joomla 2.5

Software Recommended Minimum
PHP 5.4+ 5.2.4+
Supported Databases:
MySQL[1] 5.0.4+ 5.0.4+
Supported Web Servers:
Apache (with mod_mysql, mod_xml, and mod_zlib)[2][3] 2.x+ 2.x+
Hiawatha (with UrlToolkit support) latest 8.0
Nginx 1.1 1.0
Microsoft IIS[4] 7 7


References

  1. 1.0 1.1 Joomla is not yet compatible with MySQL 6.x.
  2. 2.0 2.1 In order to use Search Engine Friendly URLs, you will need to have the Apache mod_rewrite extension installed.
  3. 3.0 3.1 The mod_suphp extension or mod_fcgid extension is recommended to enable Joomla to upload and execute files using secure file permissions.
  4. For Microsoft IIS you need MySQL 5.1 or newer.