Actions

What is the Mootools 1.2.4 upgrade plugin?

From Joomla! Documentation

Revision as of 18:14, 15 July 2010 by Dextercowley (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

Version 1.5.19 adds a new system plugin called "System - Mootools Upgrade". This plugin is installed in a disabled state the first time you login to a 1.5.19 site. Since the plugin is disabled, it has no impact on existing Joomla! 1.5.19 sites unless you choose to enable it.

When enabled, this plugin overrides the JHTMLBehavior and loads the new Mootools 1.2.4 Javascript files instead of the version 1.1 files. Compatibility with existing Mootools functionality is preserved using the Mootools compatibility layer.

If you require the expanded functionality of Mootools 1.2.4, then you should enable this plugin. If not, then you don't need to do anything.

If you use this new plugin, please report any issues you find through the normal bug reporting process. If you use this feature, we would like to hear feedback on how this works for you. Thanks!